1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B20/b16 problems

Discussion in 'Civic and del Sol - EG and EK' started by B20 newguy, Dec 2, 2010.

  1. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    I have a b20 b16 swap which worked fine at first but now verytime I accelerate the motor dies off unless I keep the clutch in full way and acelerate to about 2500 rpm and let go of the clutch I really need help! Any thoughts?
     
  2. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    is the cel light on
     
  3. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    Yes it is me an a friend have checked the codes only ones that showed were iacv
     
  4. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    about what rpm does it die at. It could be the distributor causing a problem.
     
  5. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    We think it could be the sensor maps or the ecu besides thee iacv
     
  6. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    D the motor dies off imediatly if I don't keep my foot on the clutch it's like I can't accelerate without burnin my clutch
     
  7. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    the iacv wont cause it to die out like that.. if the map sensor was bad it would throw a code, you could try a different ecu but doubt that too..
     
  8. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    I have a jdm obd1 p72 would the cel codes be the same as the usdm and would I be able to run my swap with that because the ecu I have doesn't even have the sticker with the ecu number so idk wat ecu It could be. I kno I need the usdm p72 for me to run my car but other than the iacv no other codes have been thrown up wat is another possibility for this problem
     
  9. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    i dont know much about the jdm ecu's but i think they dont have the emission shit in them so that could cause a problem. maybe someone else here knows about them. but the iacv will only cause it to rev up and down.
     
  10. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    I'll check the codes later and see what they say I'll keep u posted
     
  11. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    hey if you dont get my pm i got a p72 hit me up we can work something out
     
  12. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    JDM P72 does not look for an Evap Purge Solenoid but it still looks for O2 sensor. From my knowledge...its the only difference in terms of OBD1 sensors/plugs/wires. Mine had a PCV and O2 but no Evap Purge. I got a B16A3 IM and hooked up the purge to my USDM harness and USDM P30. My motor has been converted over.

    I don't mean to be an ass but you really need to deal with the code first. ALWAYS deal with the easiest stuff first....like codes your ECU is telling you. Try to clean the IACV and see if that makes the code go away. Its really hard to figure out a problem when you have your ECU telling a problem first. You IACV is bad or dirty or you might have bad wiring issues somewhere.
     
  13. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    Besides the iacv we found that if we unpluged the sensor maps the car wouldn't do anything or turn off so we think it mite be the sensor map wiring that's bad
     
  14. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    ?!

    Ok so I ches my ecu codes and it says I got bad map sensor and tcm signal b I know what the map sensor is buy idk wat the tcm signal b code is for any ideas
     
  15. Fernpatch

    Fernpatch Member

    Messages:
    572
    Likes Received:
    19
    Joined:
    Jul 28, 2008
    Location:
    Bellingham,WA
    was this ecu out of an auto car?
     
  16. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    No ibeleive it's from a manual car
     
  17. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    Does anyone know what the tcm signal b code is for because I ran the codes again and it still shows up
     
  18. hondafreak513

    hondafreak513 New Member

    Messages:
    2,053
    Likes Received:
    46
    Joined:
    Nov 9, 2010
    Location:
    O hi O
    transmission control module, so it sounds like your ecu is from an auto.
     
  19. B20 newguy

    B20 newguy WTF

    Messages:
    102
    Likes Received:
    1
    Joined:
    Sep 29, 2010
    Location:
    MARYLAND FOO
    ran the cel codes again and now it's tellin me that it's the vtec solenoid valve and the engine coolent can anybody tell me why the codes would be different from one day to the next?!
     
  20. jdmLife

    jdmLife I KILL V8s

    Messages:
    54
    Likes Received:
    3
    Joined:
    Dec 5, 2010
    Location:
    Tucson AZ
    have you checked ur tps sensor? i had a 98 gsr with an h22a swap and it did the same thing when my tps sensor went out
     
Verification:
Draft saved Draft deleted

Share This Page