1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

b20 not starting

Discussion in 'Engine Building' started by 5speed, May 11, 2010.

  1. 5speed

    5speed New Member

    Messages:
    80
    Likes Received:
    0
    Joined:
    Jun 6, 2009
    Location:
    Wisconsin, USA
    well got a buddy with obd1 b20 block with obd1 ls head and tranny...buddy finished swap, car cranks but doesnt start up...everything has been double checked..no CEL,looks like we got fuel..new pump,filter,injectors and plenty of fuel coming out clean...and pulled out plugs and saw good spark.....good compression...maybe coil in distributor bad? the thing is when we first swapped and started it up...it started up...but the car would rev up a bit to mabye 3-4 rpm then drop back to 1 then check engine would come on and flicker on and off and on and off..then would rev up again and would repeat this for a while...so we turned it off...then came back to start it up the next day and it wont start up anymore..only cranks..any advice?
     
  2. Magana559

    Magana559 The Warden

    Messages:
    2,568
    Likes Received:
    42
    Joined:
    Aug 9, 2008
    Location:
    fresno Ca
    check your timing.
     
  3. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,482
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    yes, timing is off. re check it and make sure the tensioner is cranked tight
     
  4. 5speed

    5speed New Member

    Messages:
    80
    Likes Received:
    0
    Joined:
    Jun 6, 2009
    Location:
    Wisconsin, USA
    yeah..ignition timing off...thanks guys
     
Verification:
Draft saved Draft deleted

Share This Page