1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

backfiring with new motor

Discussion in 'Forced Induction' started by freshie, Sep 17, 2003.

  1. freshie

    freshie Member

    Messages:
    42
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    Location:
    Newtown Square, PA
    I recently got a new motor(99 d16y7 5 speed)and a auto to man conversion done onto my 97 civic but i am using a y8 intake manifold and the y7 throttle body.
    im using the 97 automatic harness(with all 4 plugs plugged into the automatic ecu) and ecu that came with my 97 civic since the 99's harness and ecu wouldnt work with my car since its ODB2B. i dont have a manual ecu yet(ecu's on its way here). i have a greddy 92-95 turbo kit on it also with an intercooler and am using the blue box as the fmu, greddy evo catback, and no cat converter.

    my exhaust reeks like gas and while driving today i backfired a couple times. the timing is set at stock, im running ngk 6f plugs and am only boosting the greddy kit's max(6psi). What could be the cause of me backfiring? Anyone have a solution, im totally stumped and am scared i might mess this engine up


    the plugs are gapped at however they come out of the box

    im guessing the gas in the exhaust smell is from running rich, how to i lean it up some? is there anyway too besides safc hack or something?
     
  2. SolReaver

    SolReaver Senior Member

    Messages:
    1,515
    Likes Received:
    0
    Joined:
    Oct 6, 2002
    did you install the old school kit's electric missing link as well as the blue pos box?
     
  3. freshie

    freshie Member

    Messages:
    42
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    Location:
    Newtown Square, PA
    electric missing link with the 92-95 kit? blue box is wired up

    it never did this when my car was automatic
     
Verification:
Draft saved Draft deleted

Share This Page