1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bad Iacv?

Discussion in 'Civic and del Sol - EG and EK' started by 94tuner, Aug 10, 2011.

  1. 94tuner

    94tuner New Member

    Messages:
    79
    Likes Received:
    0
    Joined:
    Feb 11, 2010
    Ok i have a 92 civic with d15b. I have been having problems with the car at about 1500 rpms. When it gets to about 1500rpms it acts like it is hitting the rev limiter and it does this everytime. No problems above or below 1500rpms just right in the same spot. I do have a cel but the code is for idle air temp could this be the same code as a bad iacv?
     
  2. Dj211855

    Dj211855 New Member

    Messages:
    191
    Likes Received:
    0
    Joined:
    Aug 2, 2011
    Nope,,Iat (intake air temp). fix that and see what happens.
     
  3. 94tuner

    94tuner New Member

    Messages:
    79
    Likes Received:
    0
    Joined:
    Feb 11, 2010
    Isnt the iat on the intake tube? If it is i may have a really BIG problem because i have an injen cai and it doesnt have the plug on the intake
     
  4. BIGROB90

    BIGROB90 New Member

    Messages:
    36
    Likes Received:
    0
    Joined:
    Aug 9, 2011
    Location:
    FLORIDA
    its not the iat sensor mine on my b16a isnt hooked up and drives fine. but if you have had some electrical problems or you have a po6 ecu or 2 step you might want to look at that ecu... hope i helped hit me up if you haqve more questions.
     
  5. BoostedHatch

    BoostedHatch get tha fuck out!

    Messages:
    557
    Likes Received:
    2
    Joined:
    Aug 13, 2008
    Location:
    Bossier City, Louisiana
    mine did the same thing it is my iacv
     
Verification:
Draft saved Draft deleted

Share This Page