1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BIG problem

Discussion in 'Accord' started by Hondadude141, Jul 4, 2008.

  1. Hondadude141

    Hondadude141 ¿pɐǝɥ ɹn ɥʇıʍ uıop nɥɔʇɐʍ

    Messages:
    2,621
    Likes Received:
    108
    Joined:
    Jul 17, 2007
    Location:
    TX
    alright i may be fixing to ask a completely stupid but im having a problem that i can't figure out....

    i just lowered my car with the complete skunk2 lowering spring and sport strut kit, in the front they gave me two polyurethane bushings to use so i did but now im having a major problem with the mount on top, yes the spring is seated correctly i know that for sure, and yes there is a bump stop in there but i can't figure out whats going on! look at the pictures and tell me what i need to do!

    [​IMG]

    [​IMG]

    it is like that on both sides....

    any thoughts?
     
  2. Bkkfarang

    Bkkfarang New Member

    Messages:
    302
    Likes Received:
    5
    Joined:
    Jun 29, 2008
    Location:
    Bangkok and Shenzhen
    you have the assembly together wrong , i would suggest a hayes service manual or have it towed to a shop . red part in the wrong place , goes below the upper mount . i assume this is your first spring job . expect to be flammed alot for this
     
  3. Bkkfarang

    Bkkfarang New Member

    Messages:
    302
    Likes Received:
    5
    Joined:
    Jun 29, 2008
    Location:
    Bangkok and Shenzhen
  4. Hondadude141

    Hondadude141 ¿pɐǝɥ ɹn ɥʇıʍ uıop nɥɔʇɐʍ

    Messages:
    2,621
    Likes Received:
    108
    Joined:
    Jul 17, 2007
    Location:
    TX
    first on my car with aftermarket suspension, and yes i know about the other one, there was two one is on the bottom of the top mount and the other is where its at in the picture, and i can take the flaming, i just need everyone's input
     
  5. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    Did you install the lower "washer" piece that holds the bushings?
     
  6. wikedeye

    wikedeye Well-Known Member

    Messages:
    1,772
    Likes Received:
    57
    Joined:
    Dec 14, 2006
    Location:
    Savannah, Ga.
    Did you buy them from skunk2. If so they should have com e with instructions. If not go here...skunk2.com, they have online instructions for most of there parts that you can download. If I new exactly what you bought I could have given you a direct link, but you should be able to find them. I think that the bushing should go inside the plate that sits against the suspension tower, you have yours on the outside.
     
    Last edited: Jul 4, 2008
  7. Hondadude141

    Hondadude141 ¿pɐǝɥ ɹn ɥʇıʍ uıop nɥɔʇɐʍ

    Messages:
    2,621
    Likes Received:
    108
    Joined:
    Jul 17, 2007
    Location:
    TX
    well guys we figured out what it was today, and being stupid me and i guess trying to finish quick i missed the washer below the bottom bushing on both sides..... yes yes i know stupid right? lol but all is good and she rides like a dream :)
     
  8. BrutalB83

    BrutalB83 Brutal Moderator Moderator VIP

    Messages:
    11,620
    Likes Received:
    302
    Joined:
    Jun 24, 2006
    Location:
    Rochester Hills, MI
    NOOB!!!!!11 :disgust1:

    :D
     
  9. Uncle Buck

    Uncle Buck JDMDecals.com guru

    Messages:
    198
    Likes Received:
    2
    Joined:
    Nov 30, 2007
    Location:
    Spearfish, South Dakota
    its all good.... its a common mistake and atleast you figured out your own problem before you had to invest in a new hood
     
  10. Ethan

    Ethan Well-Known Member

    Messages:
    2,945
    Likes Received:
    98
    Joined:
    Jun 30, 2008
    Hahaha its ok i would have sold em a new hood for like 20 bucks plus shipping. :D
     
Verification:
Draft saved Draft deleted

Share This Page