1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Blue AE86 Update...she runs..Yay!

Discussion in 'Other Vehicle Discussions' started by BlackTruenoAE86, Jul 13, 2004.

  1. BlackTruenoAE86

    BlackTruenoAE86 Junior Member

    Likes Received:
    Jun 14, 2004
    Hey guys,

    As most of you guys know my cars engine gave out while heading to Fourmula D houston. after a long month of waiting we assembled the engine last week and dropped it in friday and today. Its finally running!!!! It runs like a beast too bad I can't rev it high till the break in period but the new engine pulls hard and wants to be revved higher... :eek: Its like being in temtation island i feel like slamming it to the ground but know I can't. I love the car more than ever. She's running a little rich since we couldn't get the timing perfect (It got dark). Did the breaking in precedure like the book did and now just cruise around till I can get her to have enough miles. The car's sound is awesome low deep rumble. I'd like to thank Moto, Yasin, John Y., Adan, Chris, Boon, Junsei Motorsports and all the members of club4ag, H-I, Jspek, DriftMasterz, TougeFriends, 240sxForums, HachiLife, Trapspeed, Drift-Garage & Honda-Swap for being so supportive and encouraging on my headache. If you guys need some advide or help hit me up I'll be more than gald to do what I can.

    4AGE Hybrid
    The Setup:
    4AGE High-Comp Red Top 7-rib Block w/ Oil Squirters.
    Bored Block
    Bigger Pistons
    Slightly Cut Rebuilt Stock Blue Top Head Big Port

    I have alot of pictures I just need to upload them. I Dont have pictures of the Valve adjustment or the finishing off of dropping the head and hooking up everything since I didnt have a camera. I'll be sure to take some pictures of the enginebay and post them up for yall.
    Thanks Again, I'll let you know whats up after I tune it.

  2. Airjockie

    Airjockie Watanabe Whore!!!

    Likes Received:
    Jan 21, 2003
    Meriden, CT, USA
    :worthy: Cool deal dude....ya beat me.

    Need the pics and vid's....

    Mine cranks, but act's like it's not getting fuel, I might have to re-prime the fuel system....I'll find out this week.
Draft saved Draft deleted

Share This Page