1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Brake Problems HELP!!!

Discussion in 'Civic and del Sol - EG and EK' started by propel189, Feb 8, 2012.

  1. propel189

    propel189 New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Feb 8, 2012
    Ok, well I have a 93 del sol, it starting squealing bad so we changed the rear brake pads which stopped the squealing. But, a couple days later the brake light came back on and you had to press the pedal to the floor in order for it to stop. We put some brake fluid in it and it helped for a day but went back to the way it was before. But now the brakes aren't working at all and I don't know why. Can anyone help, I'd rather not take it to a shop and fix it myself.
     
  2. Blakwolf9666

    Blakwolf9666 Member

    Messages:
    226
    Likes Received:
    0
    Joined:
    Oct 15, 2007
    Location:
    Miami
    check all the hoses and lines and make sure theres no leaks. bad MC just check all the basics first mayb a bad wheel cylinder if it has drums in the rear (happened to me, lost all braking till the pedal was on the floor when that happened)
     
  3. Benner

    Benner New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Feb 8, 2012
    Check the adjusters on the rear drums.(Assuming Del-sol's had drums???). My 95 civic DX's were completely jacked from some hack that didn't know what they were doing. The piece that contacts and adjusts them as the brakes wear weren't even contacting the adjusters so the pedal went half way down before even giving any tension. May need to readjust them manually. Occasionally you'll get lucky enough that they will adjust themselves but not always.

    Had to have a friend sit in the car while I manually spun it out and rechecked. Made a 30 minute job take an hour and a half.
     
Verification:
Draft saved Draft deleted

Share This Page