1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't figure out my problem. So here's a VID!

Discussion in 'Civic and CRX - EF' started by nofxSOHCcrx, Apr 21, 2009.

  1. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV
    F**ked up car.... Video by The Jesus Of Suburbia - MySpace Video

    That's a video to what my car is doing. I can't seem to figure it out. Instead of asking over and over, I've been combing the internet for literally weeks trying to find someone with the same problem. The tach jumps around a bit, and it seems like it missfire's like a crazy. I'm not the smartest when it comes to cars, I know a bit here and there. Enough to get a by...until now. I'm replacing my IACV because I know that's no good, and without it plugged in, should just give me a rough idle, not all this lol. The problem started about a month ago, was driving down the road, and when I went to give it a good amount of gas it started sputtering and missfiring for a second, then caught up to itself and got up and went. Now it goes crazy. The main questions I have would be: Could it be my distributor? If getting a new one for a SOHC ZC, a TD02U, or a TD18U would work right? Also, could it be bad grounds causing this? Say I hit a bump, knocked a ground loose, and when under load would cause this? Any help would be appreciated. Thanks. Oh, HAHA, don't make fun of my silencer, I'm leaving it on for the REF...Oh, only code being thrown is a 14, IACV...new one coming on Thursday...Would have been today but damn Kragen sucks ass.




    Ok. No one reads after the first post lol. Replaced the IACV and Distributor. That fixed the problems in the vid. Now my problem seems to be only when I accelerate. I try to give it about half throttle and it will buck and bog like crazy, let off the gas a little, and runs like normal. The idle sounds great though. So next I'm going to replace the fuel filter, MAYBE the pump, and the Main relay also, I don't hear it going everytime I go to start my car.
     
    Last edited: Apr 24, 2009
  2. Crx Kid22

    Crx Kid22 New Member

    Messages:
    105
    Likes Received:
    1
    Joined:
    Apr 13, 2009
    Location:
    boring, oregon
    thats pretty messed up... hows the camshaft? distrbutor?are those the right plugs?
     
  3. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV
    Yeah, they should be, everything was running just fine, then all of a sudden BAM...this shit starts happening.
     
  4. D16SiHatch

    D16SiHatch New Member

    Messages:
    1,297
    Likes Received:
    44
    Joined:
    Sep 7, 2007
    sounds like you have toda vtec killer cams in there, lol. in all seriousness though sounds like your dizzy is muffed up.
     
  5. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV

    HA...I wish. That's kind of what I was thinking, but not sure, and didn't want to go spend 1-200$ on a new one if it's something stupid and cheaper.
     
  6. Crx Kid22

    Crx Kid22 New Member

    Messages:
    105
    Likes Received:
    1
    Joined:
    Apr 13, 2009
    Location:
    boring, oregon
    check all your sensors for stuff that has fallen out or come loose somethin is berzerk
     
  7. sevenhillsbilly

    sevenhillsbilly New Member

    Messages:
    613
    Likes Received:
    3
    Joined:
    Feb 18, 2008
    isnt the dizzy for the sohc zc a td42?
     
  8. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    i had this happen to my EG once.. the distributer bearing went out
     
  9. m90polk

    m90polk Member

    Messages:
    137
    Likes Received:
    0
    Joined:
    May 28, 2007
    Location:
    ri
    yeah I would go an check the sensors and make sure they are all fine.....also check the TPS because it can give you problems like this if the voltage is not right.....had it happen on my car, replaced all the sensors and sold the car to a guy, the next day calls me up and asks if I replaced the TPS said yeah, an he was like oh the reason it had the erratic idle was the TPS wasn't properly adjusted so the voltage kept fluctuating and caused the erratic idle. Someone posted on H.S. previously on how to propely test it
     
  10. TurboRex90

    TurboRex90 Golden EG

    Messages:
    1,250
    Likes Received:
    31
    Joined:
    Jul 15, 2008
    Location:
    Maryland
    You can get them on ebay for like 100$, theres a seller called the Distributor King or something but, i have a TD-42U on my D16Z6, but i had it rebuilt with MSD parts. Anyways. Good luck!

    Here:
    eBay Motors: Distributor 92-95 HONDA CIVIC VTEC TD-42U TD42U DEL SOL (item 320360438385 end time Apr-24-09 18:49:45 PDT)

    eBay Motors: DISTRIBUTOR HONDA CIVIC DELSOL 92-95 TD-42U 1.5L 1.6L (item 260394485741 end time Apr-25-09 20:05:31 PDT)
     
  11. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV
    I think the TD42U is for the 92-95 Vtech ZC. Mines 89-91 non-vtec sohc ZC. I think I'll just replace the dizzy, and go from there...This whole thing is becoming such a pain in the ass. Just trying to get it to the ref so I can drive my car on the road again. I've had the TD02U on my car since I've had the ZC and it's ran just fine until now. So should I just purchase a new one of em?
     
    Last edited: Apr 22, 2009
  12. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV
    TD03U 1988-1991 JDM ZC 1.6L (OBD0) Distributor
    what about this one though? TD03U. It says for first gen ZC, OBD0. doesn't say anything about sohc or dohc though. would it make a difference?


    Application Guide

    TD01U Civic 88-91 (1.5L)
    TD02U & TD18U Civic 88-91 Si (1.6L) & CRX 88-91 Si (1.6L)
    TD22U Civic 88-91 JDM B16A (Japanese Spec.)
    TD41U Civic 92-95 (1.5L)
    TD42U Civic 92-95 Si (1.6L)
    TD43U Civic ZC Engine (2nd Gen. ZC)
    TD80U Civic 96-98 (1.6L Non-VTEC)
    TD63U & TD73U Civic 99-00 Si DOHC VTEC (1.6L)
    TD31U & TD34U Accord 90-91
    TD52U Accord 92-93
    TD58U Accord 94-95 (2.2L)
    TD76U Accord 96-97 (2.2L)
    TD89U Accord & Prelude Type S DOHC VTEC H22A
    TD77U Prelude 97-02 VTEC
    TD59U Prelude 92-96 non-VTEC (2.2L)
    TD60U Prelude 92-96 JDM VTEC (2.2L Internal Coil)
    TD61U Prelude 92-96 VTEC (2.2L) & 92-96 non-VTEC (2.3L External Coil)
    TD97U CRV 99 & up (2.0L)


    ACURA Application Price

    TD03U Integra 88-89 (1st Gen. ZC) (1.6L)
    TD23U & TD24U Integra 90-91 (1.8L)
    TD44U & TD68U Integra GSR / 92-95 JDM B16A
    TD55U Integra 92-93 (1.8L)
    TD81U & TD84U Integra GSR 96-02 & JDM B18C
    TD86U & TD87U Type R 96-02 & Civic SiR 99-02
    TD85U Integra 96-98 (1.8L & CRV 96-98 (2.0L)

    Found this on another forum, figure I would post it here for searching purposes, and later on info.
     
    Last edited: Apr 22, 2009
  13. TurboRex90

    TurboRex90 Golden EG

    Messages:
    1,250
    Likes Received:
    31
    Joined:
    Jul 15, 2008
    Location:
    Maryland
    Im sorry but i HAVE to correct you on something. Its VTEC... not VTECH.. sorry.

    The SOHC Vtec motor is the D16Z6, i believe the non-vtec SOHC (ZC) is the D16Z5?. correct me if im wrong though.
     
  14. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV

    I know, I could have swore I went and edited that...maybe I missed that one. I'm going to use that as my sig now...sohc non- VTEC zc is just the same as a D16A6, except for the cams right? I'm still curious if I should just get the same dizzy over again...the TD02U.
     
  15. TurboRex90

    TurboRex90 Golden EG

    Messages:
    1,250
    Likes Received:
    31
    Joined:
    Jul 15, 2008
    Location:
    Maryland
    A6 really?, hmm those are the pistons im looking for for my setup. Those pistons in my DOHC ZC block and SOHC Z6 head will up the compression to 9.9:1. Plus boost :)

    Didnt know it was the non vtec SOHC (zc).
     
  16. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV
    So I bought a TD02U, and put it on, haven't started it yet though. I'm going to wait an hour for my IACV to get in, then put that on so I'm completely ready. Hopefully it will be problem solved. I'll prolly post a vid up after.
     
  17. nofxSOHCcrx

    nofxSOHCcrx New Member

    Messages:
    254
    Likes Received:
    2
    Joined:
    Mar 6, 2009
    Location:
    Las Vegas, NV
    O.K. I put the TD02U on, and it runs WAAAAY better. I can go through the RPM range like no other. BUT....It has the same original problem. Went for a little test drive down the road, and when I go to give it some gas it bucks and bogs and doesn't want to go until I back off the pedal a bit. I can get through the RPM rangs going slower, just can't give it a lot of gas. Could this be maybe a bad TPS? or maybe even the ground from the TPS no good?
     
  18. yodaesu

    yodaesu New Member

    Messages:
    53
    Likes Received:
    0
    Joined:
    Dec 4, 2008
    Check your ignition line including the dissy rotor, if theres no problem next bet would be the fuel line, check your fuel press
     
  19. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    Sounds like the meanest NA honda build of all time! lol

    Seriously though, the cylinders are firing at completely random times, lots of them sound like they are firing after the exhaust valves are open, which could burn your valves up. Be careful with that. I'd check timing first. Make sure it didn't jump a tooth or two or something. Everyone else seems to be on the right track already though. Cap is in good shape? rotor? No cracks, pitting, melty spots, bent contact points, any of that going on?
     
  20. 97h22dxcoupe

    97h22dxcoupe senior member

    Messages:
    332
    Likes Received:
    4
    Joined:
    Mar 29, 2009
    Location:
    Coffeyville, ks.
    definately the dizzy ,replace it becuz same thing happened to my h22 vtec when i swapped it in my 97 dx i replaced it and it ran perfect,so go with that ...
     
Verification:
Draft saved Draft deleted

Share This Page