1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Car hesitates and stutters during acceleration...o2 sensor?

Discussion in 'ECU's, Electronics, and Tuning' started by BigBoy, Oct 27, 2005.

  1. BigBoy

    BigBoy Senior Member

    Messages:
    168
    Likes Received:
    0
    Joined:
    May 10, 2005
    Location:
    cali 818
    when i floor it it accelerates fine but when i apply the gas lightly...it gets jumpy and sometimes it feels so slow especially around 1-3K and then it jerks forward. Could this be cause by a bad o2 sensor? I tried plugs and dizzy already. What about fuel filter?
     
  2. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    might wanna check map sensor voltage too...
     
  3. SpoonTuNed

    SpoonTuNed Senior Member

    Messages:
    139
    Likes Received:
    0
    Joined:
    May 26, 2005
    Dude im almost positive its your o2. My civic is doing the same thing right now and i dont have either o2 hooked up. when i take off it kind of sputter and runs rough till about 4k rpm then it take off almost like a vtec engagement or something. Any ways id check your o2 just cause im having the same symptoms.
     
  4. aasaa666

    aasaa666 Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 1, 2005
    You should get a book for your car like chilton or haynes. In the book it will tell you how diagnose and decode ECU codes. This is the best way to find out the real problem. Id say 90% of the time its whatever code they throw at you (unlike American cars which tells you its one thing but most likly its something else). This will help you to determine if it is your O2 sensor, because theres no sense in wasting money on an O2 sensor if that isn't the problem. I can tell you this from experience, and that is that if your car feels like its hesitating to accelerate to highway speeds then the problem is most likely EGR because that is the other most common problem. So you actually have 2 things to juggle around: its either the EGR Valve or the O2 sensor and that 10% I was talking about... thats the catalytic converter. EGR Valve man, EGR because the O2 sensor wont give you that much problem. The only thing I can see the O2 cause problems on would be your gas mileage...yeah that would do it to you.
     
  5. D See 2

    D See 2 Senior Member

    Messages:
    2,405
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Baltimore, MD
    wtf, we don't even know what kind of car, year, ecu, swap, etc... I don't see how it's possible to make an accurate conjecture.
     
  6. aasaa666

    aasaa666 Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 1, 2005
    DTEC is right. We don't have any clue as to what car you have. I guess we can assume you probably have a Civic, Accord, Integra, etc... : lol: but anyway, try your best to diagnose the problem because an O2 and EGR Valve isn't cheap. Have fun and good luck!
     
  7. APEXi

    APEXi Senior Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Jun 5, 2005
    i have the exact same problem with my b18c1 in my eg, i put my foot to the floor on the gas pedel unker 2-3k and it stuterters, then pick up as normal. rite i check for codes today and my check engine light jus stays on constantly while checking for codes. when im not checking for codes the light isn't on.. dus this mean im throwing a code 1? o2 sensor?

    any help would be great thanks..
     
  8. APEXi

    APEXi Senior Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Jun 5, 2005
    im also have trouble starting my car at times, so could it also possibly be plugs and leads?

    soz i dont mean to jake this thread...
     
  9. VTECPOWER

    VTECPOWER Senior Member

    Messages:
    1,683
    Likes Received:
    0
    Joined:
    Oct 6, 2003
    Location:
    Winchester, VA
    Make your own. [​IMG]
     
  10. BigBoy

    BigBoy Senior Member

    Messages:
    168
    Likes Received:
    0
    Joined:
    May 10, 2005
    Location:
    cali 818
    91 civic w/b16 p28 ecu

    when i converted to obd1 i bought a brand new 4wire o2 sensor. The stutering and hesiation got worse after tuning. possible a fuel problem?
     
  11. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    you stopped tuning the engine when the hesitation got worse...?

    dont mean to break your balls dude, but i would checked that shit out before i got on the dyno or whipped out the wideband.
     
  12. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl
    not getting ANY codes? i had similar symptoms before (sputtering at ow rpms, running rich, started to sputter when i cruised the same speed for afew minutes till i pressed the throttle a little. might need to Replace you ect sensor. It's like 24 bucks from autozone. That helped me
     
Verification:
Draft saved Draft deleted

Share This Page