1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

car revs to 6 k rpm at idle-HELP

Discussion in 'General Tech and Maintenance' started by combz, Apr 29, 2007.

  1. combz

    combz New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Dec 15, 2006
    I own a 1998 honda civic , Recently turbo'd
    Worked A1, for 5 days , no problems.

    Was driving home after just getting gas, doing about 60km/h, barely touching the throtlle then i pressed it a bit in and i noticed my blow off valve started to flutter a bit and the car started to accelerate, i knew something was fuckked right up, so i immediatly shut the car off , were talking a time frame of about 5 seconds from when i noticed it to when i shut the car off.
    I assumed my throttle plate just got stuck open...but nope, popped off my IC piping and the throttle plate is comepltly closed!! WTF

    Start the car now and it instantly revs to about 5k rpm, maybe more, and doesnt go down, The car is comepletly warmed up too.
    Tryed numerous things on the side of the road...the throttle body is sucking in air i guess, when i started it my buddy put his hand there and said she was, i got him to plug both of the holes on the inside of the throttle body and it had no effect,

    Makes me think vaccuum leak..but i checked and from what i can see there are no leaks in my hoses and they are all attached still. Even if it was a hose, i dont think it would fucking rev to 6 grand, thts pretty fuckked for the throttle plate being fuly closed.

    Could it be electrical?
    I dont know much about all the sesors, liek how they would effectt he car if they fuckked off. Like the TPS, the MAP, the CFS etc.

    Like i said the car ran perfect i have put over 500km on it in 4 days, drove 100km on the highway, no over heating or anything it runs mint.

    I should mention that the most recent mods were the turbo kit, did the timing belt, head gasket , ARP headstuds, intake manifold etc.
    Also, theonly thing i haven't put back to where it shuld be is torquing the crank pully back to 100ftlbs or whatever...but really...

    Anyways ever have this problem? It was so random how it occured.
    Please ideas are welcome. We should get to look at it a bit more after work tomorrow. But i fucking hate starting it up and trying to diagnose a vaccum leak while the car is revving so damm high. Is there any other way to do it?Leakdown test...never done before but is that what they do?

    HELPPPPPPP, godam car i wana slap its face.
     
  2. SneakySedan

    SneakySedan Junior Member

    Messages:
    80
    Likes Received:
    0
    Joined:
    Oct 3, 2004
    Location:
    Central NC
    Is your idle screw still in there? Maybe not a vacuum leak but a leak somewhere in the intake, after the throttle body. Electrical or not, the engine still needs to be pulling air from somewhere to feed it at 5K. Double check all the hardware make sure everything is tightened down/sealed and get back to us.
     
  3. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    Best way to check for a vacuum leak is with a "smoker".
     
Verification:
Draft saved Draft deleted

Share This Page