1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cel code 15... need help!

Discussion in 'Civic and CRX - EF' started by mikey bottles, Oct 14, 2009.

  1. mikey bottles

    mikey bottles Prof. Bottles

    Messages:
    417
    Likes Received:
    6
    Joined:
    Nov 21, 2006
    Location:
    S. Jersey
    hey guys, been a while since ive posted but ive run into some issues so i come to you once again! working with a 90 civic hatch, has a swapped d16a6 in it, its got the si dash and engine harness as well, the problem im having is it will intermittenly just shut off, while driving, but will start up again within a minute or so. last time it kicked out a code 15, which is ignition output signal missing or defective ignition output signal, could this be a problem with the ignition switch itself or is there something else i should be looking at? not finding a whole lot of useful information anywhere so hopefully someone can help!
     
  2. ZCpowerdSI

    ZCpowerdSI New Member

    Messages:
    491
    Likes Received:
    11
    Joined:
    Oct 13, 2009
    Location:
    ON, Canada
    try changing the dizzy
     
  3. ZCpowerdSI

    ZCpowerdSI New Member

    Messages:
    491
    Likes Received:
    11
    Joined:
    Oct 13, 2009
    Location:
    ON, Canada
    i bet its the igniter, it says you have a 91. if you have any 88-91 civic distributors laying around the igniter is the same and you can swap them
     
  4. mikey bottles

    mikey bottles Prof. Bottles

    Messages:
    417
    Likes Received:
    6
    Joined:
    Nov 21, 2006
    Location:
    S. Jersey
    sorry for taking so long to re-post everyone... so we think weve got it figured out, it only throws the code when it decides to sputter out and shut off, upon which it starts right back up, we found out it loses all fuel pressure at the same time, it has the wrong fuel pump in it.. instead of the strainer being off to the side (pointing toward the front of the tank) it sticks up and out toward the passenger side of the tank, so its starving for fuel, new pump going in this week sometime
     
  5. D16SiHatch

    D16SiHatch New Member

    Messages:
    1,297
    Likes Received:
    44
    Joined:
    Sep 7, 2007
    strange. you should be getting a code 43 if you were having fuel issues. i'm betting the problems are unrelated. most likely you're still going to need a new ignition module.
     
  6. mikey bottles

    mikey bottles Prof. Bottles

    Messages:
    417
    Likes Received:
    6
    Joined:
    Nov 21, 2006
    Location:
    S. Jersey
    well now it only does this at like a quarter tankish as opposed to half tank bc we turned the fuel pump off to the side (best way i can explain it) to keep it submerged in fuel longer, this of course being a quick fix until we get the new pump in the mail, but the dizzy is new, main relay is not, but u can still hear the fuel pump prime after it shuts off (turn the key to off, then back onto on position) and you can hear it prime, it def sounds like its 2 seperate issues, i totally agree, but oddly its been acting up at only a 1/4ish tank as opposed to half tank like before, honestly havnt checked spark when it happens yet bc weve been focused on the fuel issue, ill try that next time it happens
     
Verification:
Draft saved Draft deleted

Share This Page