1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CEL

Discussion in 'HYBRID -> EG-EK / DC' started by dohch22a4, Jul 30, 2003.

  1. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    I was cruising around last night in my B18C hatch when all of a sudden I threw a CEL. Oh, I was so pissed! I've had the swap for over a month now and it was immaculate! I got home and completed the circuit to diagnose what the fuck was wrong. It threw a code 23 which is the knock sensor. I took the car out for a run through VTEC to see if it was working properly and it still scoots through the second set of lobes like a champ. I have no clue why I'm getting this code thrown at me. I figure that if the knock sensor was fucked up, VTEC just wouldn't work. Has anyone had this problem before? Does anybody know how to fix it? Any help is much appreciated. Thanks in advance! :worthy:
     
  2. darwins_vtech

    darwins_vtech Senior Member

    Messages:
    250
    Likes Received:
    0
    Joined:
    Jun 4, 2003
    Location:
    Wisconsin
    check the wire and make sure that it hasn't become undone and that it didn't come out of the ECU Plug. Thats all I can think of. the knock sensor doesn't have anything to do with not making v-tec work.

    Darin
     
  3. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    I was under the impression that without the knock sensor, VTEC solenoid, and oil pressure sensor, VTEC will not work and that all three must be intact in order for VTEC to actuate.
     
  4. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
  5. chet

    chet Senior Member

    Messages:
    888
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    st petersburg, florida
    ...the knock sensor does matter.

    ecu's like a skunk2 p28 don't recognize knock sensors...but OEM honda ecu's look for them.
     
  6. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    Does the knock sensor CEL mean that the sensor is totally disconnected or that there's a distorted message being sent to the ECU? I'm really not good with wiring/electrical stuff. Should I get the connections resoldered? Could it possibly just be a loos connection? How much do you think a new knock sensor would be if that's what I need? Has anyone heard of knock sensors going bad?
     
  7. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    too much shit causes the knock sensor to go off.
    a forged piston makes enough rattle to set it off. thats why ALL top end systems do not use a knock sensor input.

    first thign to do is to re-set the ecu so as to clear the code.
    then drive around again, and wait till it comes back on, if it does at all.

    it might be a one time thing, but uintil you clear the code, its in the system and will continue to show you the cel.
     
  8. dohch22a4

    dohch22a4 Senior Member

    Messages:
    1,744
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Spokane, WA
    Thanks, pissedoffsol, I cleared the memory on the ECU and drove around for a while. The light never came on, even scooting through VTEC.
     
Verification:
Draft saved Draft deleted

Share This Page