1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CEL

Discussion in 'General Tech and Maintenance' started by chb504, Jul 7, 2004.

  1. chb504

    chb504 Senior Member

    Messages:
    156
    Likes Received:
    0
    Joined:
    Jun 8, 2003
    Location:
    Louisiana
    Hi, my check engine light came on and i was wandering what causes this light to come on. I've replaced the o2 sensor tonight and I disconnected the battery and plugged it back and the light is still on.... so what other things causes the light to come on?
    thanks,
    -danny
     
  2. B18aCRX

    B18aCRX Senior Member

    Messages:
    232
    Likes Received:
    0
    Joined:
    Sep 3, 2003
    Location:
    Central Coast, CA
    Take a look at the light on your ECU and see what code is flashing. That will tell you exactly what is wrong.


    If it's the car in your sig:

    Check Here
     
  3. chb504

    chb504 Senior Member

    Messages:
    156
    Likes Received:
    0
    Joined:
    Jun 8, 2003
    Location:
    Louisiana
    I looked uner the dash by my ecu...there isn't a plug that has a black and brown wire together in one harness. there is a black and blue/white, and a brown and green.... so i connected the black and brown from the different harness and did what the artilce said so if i did anyting wrong, please tell me. The CEL only flashed once throughout the entire time, so i don't know if that was it, or if i was doing something wrong.
    thanks
    -danny
     
Verification:
Draft saved Draft deleted

Share This Page