1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CEL's 41 & 2 in 92 b16 teg

Discussion in 'HYBRID -> ED-EF / DA' started by JayDeeEmDC4, Jan 11, 2006.

  1. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
    Im getting codes 41 and 2 on my 92 integra w/ a JDM b16a. As of 3 days ago my car would hesitate and have major dead spots and once in a while when i would shut it off and try to immediately start it up again it would just crank and crank and crank then finally start and then stall abruptly. but once i started if after that it was fine all the way until it decided to do it again on a restart. but it felt more like a timing issue so I shot it @ base and it mostly went away. Now since i did my swap ive always had a code 2, electrical load detector which im told is on most cars with swaps seeing that it was also on my b16 eg 3 yrs ago. But anyway i decided to check the cels again and now im getting 41 as well (primary o2 sensor) My question being what kinda effects fo these 2 cel's have on overall performance? and is this my culprit for the starting issue?

    Thanks in advance....
     
  2. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    replace or rewire the o2 sensors. im pretty sure it'll fix the issues.
     
  3. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
    How many are there?

    I have a 92 DA with a JDM B16 from an XSi
     
  4. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
  5. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    as far as i know, only 2. there may be more.
     
  6. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
    okay, but def atleast 2? and what r some symptoms of a bad / unplugged o2?
     
  7. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
    Im sorry i just checked again and ur right my 1st code isnt 2 its 20 because its 2 long blinks and my second code is 4 long and 1 short that would make for codes 20 and 41 correct?

    So my question is mainly about code 20, ELD? What is it and how can I get it to go away and does it maje my car run any different? My friend who did my 1st b16 in an eg said that code my on that swap of mine too and it usually is on swapped cars , it has something to do with the alt and fuse box. Any truth?

    UPDATE: I just checked and my o2 is plugged in, could it be bad? How do I check?
     
  8. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
  9. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl
    Im havibg the same ELD code. pm me when you get it fixed. Could his o2 wires being mismatched be a factor? This question is to all that can help
     
  10. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
    Up to date I am getting codes 20 and 41. This code 20 (Elect. Load Detector) what does it mean and how can I fix it, my friend said not to worry cuz its on most swaps but yesterday my alternator blew on me, is it cuz of this ELD code? But I also pressure washed my motor that day and the alt. def got wet...

    I just picked up a brand new Universal O2 Sensor from Advance Auto Parts yesterday, only things is it doesnt have a plug on it so I have to hard wire it in...How do I tell what wire is which? And will this one be sufficient?

    Thanks in Adv.
     
  11. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl
    is it a 4 wire o2? these are the possible wiring diagrams depending on which o2 you have.

    Ecu adapter color----02 sensor----or--- 02 sensor --------------- Or o2 sensor

    white---------------------white----------------- white--------------------white
    blue-----------------orange/black-------black(next to green)-------orange/white
    Red-------------------yellow/black----------black(next to white ------yellow/black
    Black----------------- Green/white-----------green -----------------green/white


    hope this helps. big thanks to ripperbone
     
  12. JayDeeEmDC4

    JayDeeEmDC4 Member

    Messages:
    78
    Likes Received:
    0
    Joined:
    May 7, 2005
    yes it is a universal 4 wire sensor with 2 white 1 black 1 gray...
     
Verification:
Draft saved Draft deleted

Share This Page