1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Check engine light came on

Discussion in 'General Tech and Maintenance' started by nismogod, Oct 26, 2005.

  1. nismogod

    nismogod Senior Member

    Messages:
    1,031
    Likes Received:
    0
    Joined:
    May 31, 2003
    Location:
    Deltona, FL
    Ok, my check engine light used to come on, and when i checked the CEL codes it was

    9*- Accord Civic CRV CRX Del Sol Odyssey Prelude
    85-98** 86-98 97-98 85-91 93-97 95-98 85-98
    CYP Sensor (Cylinder)
    defective circuit or unplugged / defective sensor
    * not a valid code for any throttle body injection Hondas
    ** not a valid code for V-6 engines


    now it used to break up bad up top. And cause of the code, we replaced the whole distributor with a brand new one. Problem went away. and so did the code. Well, the code is back. After maybe a week of absence. Car still doesn't break up near the top, but sometimes it feels like its misfiring. and the CEL code is the one shown above. WTf? any ideas

    btw, its a obd1 p28 running an h22 in an EG.
     
  2. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    i would have recommended a p72 for an H22 EG...id check the wiring to the sensor
     
  3. infamouz

    infamouz Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Sep 8, 2005
    Location:
    Sacramento, C.A.
    just didnt really feel like starting another tread, i thought it would be a waste. anyone of you guys know which ecu to use when changing over a jdm b16 to a usdm in order to smog.
     
  4. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    first...dont worry about having too many threads. second check references before you post. third search before you post. fourth its a p30. As far as a smog test is concerned, your B16 has to be as close to a del sol vtec as possible.
     
  5. infamouz

    infamouz Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Sep 8, 2005
    Location:
    Sacramento, C.A.
    i freakin love you man. any question i have you always answering it quicky. they should make you a mod or something. good looking out.
     
  6. nismogod

    nismogod Senior Member

    Messages:
    1,031
    Likes Received:
    0
    Joined:
    May 31, 2003
    Location:
    Deltona, FL
    i'll check the wiring again, but it all seemed fine last time. btw, vtec doesn't engage now. lol. ima blow the car up.
     
  7. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    youre probably in limp mode. my lude doesnt hit vtec with a cel either. id definitely check the wiring from the ecu all the way to the ckp. its been known to get twisted in the oil filter (trust me)
     
  8. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    I really dont have the knowledge to be a mod...and most of them are b's friend anyway...id rather not...people might expect too much of me.
     
Verification:
Draft saved Draft deleted

Share This Page