1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Check light on EF9 hb with b16a swap

Discussion in 'HYBRID -> ED-EF / DA' started by Jdubspeeds, Dec 18, 2003.

  1. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    So i was racing this integra gsr (winning at that) mis shifted and went from the 3rd to 2nd. When it went into second it kicked it out of gear and my check engine light went on immediatley after. It also is really boggy until i get above 3k then it seems to run ok. I checked the code on the ecu (pr3) and it gave a code 1 or single flash. I put another pr3 ecu in the car and the check engine light came on before the car was even running so its not the ecu. I check the distributor out, it looks ok. Then the next day I took my fuel rail, intake manifold, o2's and shit out and checked them out and put them back in. I also had a spoon vtec controller that I took out to see if it was the problem too. I started the car and let it idle and the check light went away and it seemed fine. Then I left my shop and about 1 mile later the check light turned back on. it also started the boggy before 3k crap as well. Im lost here guys. I took it to my local speedshop and they dont know whats up either. Anyone had a similar experience or know anything I should check?

    Current set up.
    1991 civic hb dx standar. B16a engine. Skunk2 manifold. STR 70mm TB. Obx header custom made with 2 bungs for the dual o2's. aem coi. greddy exhaust.

    :worthy: :worthy: :worthy:
     
  2. B16RacerN2NR

    B16RacerN2NR Working Hard VIP

    Messages:
    6,148
    Likes Received:
    99
    Joined:
    Feb 28, 2003
    Location:
    Moving back West...
    well code 1 is o2 sensor and you just "checked" it out...try changing it...o2 will make you run f*cked up for the most part...
     
  3. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    Yeah im going to try and change them tommorow
     
  4. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002
    dizzy and fucked up fuel injectors will cause it also.

    also check the wiring.
     
  5. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    Bought a brand new dizzy. Its in the mail 189.00 on ebay WOOT. as for the injectors.... maybe ill have them tested.
     
  6. Mugen405

    Mugen405 Member

    Messages:
    61
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    Location:
    Moore, OK
    It almost sounds like you may have bent a valve. Throwing unburnt fuel into the exhaust stream can throw the 02 readings way off and possibly throw a code.

    It's kinda farfetched, but a compression check is easy to do anyways, and since the problem seems to be related to the mis-shift, it's all I can think of.
     
  7. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    did a compression check and it was 190, 185, 185,190
     
  8. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
    Found problem. It was code 10 my bad! Was the IAC sensor. My was melted on the tip of the sensor. I must have backfired when i misshifted or something. I dunno but my cars running great NO MORE LIGHT AMEN!!!!!!!!!!!!!!!!!!!!!!! Hate that damn light grrrrrrrrrrr.
     
  9. 894DSiR

    894DSiR Junior Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Sep 27, 2003
    hay bud your welcome for the help and lunch :D
     
  10. Jdubspeeds

    Jdubspeeds Senior Member

    Messages:
    503
    Likes Received:
    0
    Joined:
    Jun 9, 2003
    Location:
    Tacoma Wa
  11. crx

    crx Senior Member

    Messages:
    141
    Likes Received:
    0
    Joined:
    Oct 17, 2002
    Location:
    cali near sac
    sience were talking about codes, any one ever get a code 2(2 quick blinks)?
    setup: crx dx, b16,pr3, dc header, aem intake. ive looked and cant find a code 2, it comes on sometimes driving regular but it doesnt make the car run funny or anything

    thanks
    -joseph
     
  12. 894DSiR

    894DSiR Junior Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Sep 27, 2003
    1 fast blink is Primary O2 sensor problem 2 fast blinks is for Secondary O2 sensor
     
  13. crx

    crx Senior Member

    Messages:
    141
    Likes Received:
    0
    Joined:
    Oct 17, 2002
    Location:
    cali near sac
    i see thanks buddy

    -joseph
     
Verification:
Draft saved Draft deleted

Share This Page