1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

civic type r swap fuel problems can anybody help?

Discussion in 'HYBRID -> EG-EK / DC' started by ajmj, Aug 1, 2003.

  1. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    I swapped a b 16b on my 1998 civic hatchback, and my B & M EGT guage reads 78 psi, and when I drive the car when it reaches about 2500 rpm it starts to bog down and wont go anymore, I tried everything. The timing on the car is perfect, I have new fuel filter, and a aem fuel regulator. The weird thing is when I tried to adjust the fuel it wont even change the psi, I took off the walbro fuel pump because it was pumping over the 100psi mark on the guage. I know it is something to do with the fuel but I have no other ideas of what to do. I did my swap right because there are no check engine lights and the car starts and goes but the only problem is when I put too much gas it starts to bog down. I took it to a local shop here but they didnt know either. I hope somebody can help me or give me some advice because I dont know where else to turn to. Thank you.
     
  2. khrisb

    khrisb ******

    Messages:
    1,807
    Likes Received:
    4
    Joined:
    Apr 5, 2003
    Maybe injectors are too big???
    I dunno
    Sounds bad tho...
     
  3. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    Thanks for the reply but the injectors are the stock civic type r, and I had em cleaned and flow tested and they are in perfect condition. I bought the motor in a complete package so it came with everything I needed.
     
  4. darwins_vtech

    darwins_vtech Senior Member

    Messages:
    250
    Likes Received:
    0
    Joined:
    Jun 4, 2003
    Location:
    Wisconsin
    when you hit 2500 rpm does the motor die down to about 500-700rpm before you can hit the gas and it will go again? (in other words, can you go past 2500 rpms or no?)

    Darin
     
  5. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    i would double check your timing, also test the compression of each cylinder, did you change your plugs?
     
  6. B16

    B16 Super Moderator VIP

    Messages:
    11,539
    Likes Received:
    534
    Joined:
    Sep 30, 2002
    Location:
    yay area, CA
    wow, that fuel pressure is pretty high, i think i had mine set at 40lbs.
     
  7. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    thanks for the replies guys, the car will go past 2500-3000 rpm if I go really light on the pedal but if I put to much gas it bogs down, so the car will barely take off and when I put a lot of gas on it bogs down, the compression is right on my car I just checked it and my plugs are brand new and I also had the timing checked. I dont know what else could be wrong with my car.
     
  8. darwins_vtech

    darwins_vtech Senior Member

    Messages:
    250
    Likes Received:
    0
    Joined:
    Jun 4, 2003
    Location:
    Wisconsin
    disconnect the TPS THROTTLE POSITION SENSOR once and see if will go past 2500 rpm ok. maybe the sensor is off or broken. I had a similar problem. I couldn't go past 2500 rpms at all and it was cause my tps was broke.

    Darin
     
  9. Racecraft

    Racecraft Junior Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    May 5, 2003
    EGT-Exhaust Gas Temp Doesn't read in psi

    It sounds like this is your fuel pressure gauge and if that is true no wonder the car drives like a dog as you should have around 35psi stock. You have your fuel pressure regulator not working/adjusted too high or your return line is not connected/blocked.


    I would say it is unlikely to be a sensor prob if you have no CEL.
     
  10. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    Sorry for the wrong information my fuel pressure guage reads in degrees and its on 78 and I tried adjusting it with my regulator and it still didnt go down. My guage is working and my aem fuel regulator is working also because I used it on my brothers car and it work. The weird thing is the pressure doesnt go down on the guage. The only time it went down is when I took the walbro fuel pump and when I had the upgaraded fuel pump it was reading well over a hundred on the guage. Mr. Darwins_vtec I tried unplugging the tps sensor and the car died and it wont start and it was giving some tps sensor codes so I couldnt drive it and find out if it went over 2500. thanks for the advice and hopefully someone can help me.
     
  11. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    did your swap come with all stock fuel components? if so I would reinstall them, you don't need a fuel pressure regulator anyway they are waste of money.
     
  12. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    also are you using the jdm throttle cable?
     
  13. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    my swap came with all the stock components and I was using my stock throttle cable but I bought I just installed a 1999 civic si throttle cable cause it was too long. Hey CTR 97 can you tell me how you wired your ecu, thanks
     
  14. D See 2

    D See 2 Senior Member

    Messages:
    2,405
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Baltimore, MD
    sounds like a TPS problem to me... did your car have the vertical throttle body? i know that the ctr does not but i think your car did stock. if so, you have to swap the two outter wires on your tps sensor plug.

    and how did you wire your IACV?
     
  15. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    with my swap the ecu just plugged right in
     
  16. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    CTR 97 on your ecu, you didnt have to run the knock sensor or the v tec wires? With my IACV I changed the sensor with the IACV civic type r wiring harness so it would fit? If the TPS sensor are wired incorrectly doesnt the check engine light come on? because I dont have any check engine lights.
     
  17. D See 2

    D See 2 Senior Member

    Messages:
    2,405
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    Baltimore, MD

    no, CEL will not come on. try reversing the two outter wires. i bet that does it.
     
  18. ajmj

    ajmj Junior Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jul 31, 2003
    DTEC hopefully thats the problem, I will try it tommorrow and let you know how it goes. I only have to switch the two outer wires right. Thanks for tryin to help me.
     
  19. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    on my harness there was already a knock sensor and vtec wires. i have an ex which had the sohc vtec motor.
     
  20. 95eg1typer

    95eg1typer New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    May 15, 2009
    did anyone find out the cause of this problem!!!? i have the same issue

    if you found out the cause id love to know b/c i have the same problem!!! on a 95 civic dx .. cant figure it out its driving me nuts ive done all the same you have even checked vacumm, map, tps, timing, fuel injectors, fuel pressure regulator, if switching the wires worked can you let me know?
     
Verification:
Draft saved Draft deleted

Share This Page