1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cluster Problems

Discussion in 'ECU's, Electronics, and Tuning' started by 2cool4vtec, Jun 16, 2003.

  1. 2cool4vtec

    2cool4vtec Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jun 16, 2003
    for some reason my guages never light up when i turn my car lights on and as of recently my short circuits have been getting worse.. i have a 92 civic si.. for example i notcied when i tap on the brakes my corner lights go on.. and my dome light stopped working.. then eventually these problems go away but alwasy come back.. i checked my fuses and found nothing.. im not to good w/ electrical stuff.. so wat shoud i do in reference to this problem? how can i check 2 see wat wires are cuasing the problem and where to start to look?
     
  2. Gen2Teg

    Gen2Teg Senior Member

    Messages:
    554
    Likes Received:
    0
    Joined:
    Jan 2, 2003
    Location:
    san francisco
    wiring can get pretty complicated so i would just take it to a shop, and it can get pretty exspensive so i'd try and have one of the guys do it as a side job. where are you located at???
     
  3. sleepercivic88

    sleepercivic88 Junior Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Jun 19, 2003
    Same thing started happening to my 89 civic hatch and all it was was bad grounds. Check your tranny and head ground and make sure there is no corrosion and they are on tight. Also on mine there is a ecu ground attached tothe wiring harness over the tranny that bolts onto the clutch cable bracket. Hope thats all it is.
     
Verification:
Draft saved Draft deleted

Share This Page