1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cluster ???

Discussion in 'Civic and del Sol - EG and EK' started by custompainter, Mar 19, 2009.

  1. custompainter

    custompainter drive it like U stole it

    Messages:
    597
    Likes Received:
    4
    Joined:
    Jan 16, 2007
    Location:
    central CT
    whats up people it's been awhile
    anyway i picked up an EX cluster for my DX. is it just a plug in and go or does anyone know if the pins have to be flipped around ???

    i plugged it in and it didn't work .... I wonder if it shot anyway let me know if you have some advise
     
  2. EP3Hatch1987

    EP3Hatch1987 Meeeeooowww!!!!!

    Messages:
    284
    Likes Received:
    2
    Joined:
    Mar 25, 2008
    What kind of car do you have?
    What car did you get the cluster from?
     
  3. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Well if ya got a cluster from ya 94ex and tryed to put it in ya 99dx I could see were ya mite have a problem... details on were it came from? and why dont ya get an auto zone tack works just as well haha
     
  4. custompainter

    custompainter drive it like U stole it

    Messages:
    597
    Likes Received:
    4
    Joined:
    Jan 16, 2007
    Location:
    central CT
    sorry for the lack of info the cluster is out a of a 97 ex and i have a 99 dx
     
  5. Hfiend

    Hfiend New Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    Nov 25, 2008
    Location:
    boston
    do all the plugs from the original plug into the new one?
     
  6. custompainter

    custompainter drive it like U stole it

    Messages:
    597
    Likes Received:
    4
    Joined:
    Jan 16, 2007
    Location:
    central CT
  7. Hfiend

    Hfiend New Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    Nov 25, 2008
    Location:
    boston
    if your original cluster worked that cluster is bad
     
  8. custompainter

    custompainter drive it like U stole it

    Messages:
    597
    Likes Received:
    4
    Joined:
    Jan 16, 2007
    Location:
    central CT
    thats what i figured but i wasn't sure
     
Verification:
Draft saved Draft deleted

Share This Page