1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

clutch issue

Discussion in 'General Tech and Maintenance' started by turbowagon92, Dec 11, 2007.

  1. turbowagon92

    turbowagon92 New Member

    Messages:
    47
    Likes Received:
    0
    Joined:
    Aug 23, 2006
    hello, i just recently started driven my turbo honda accord,at first acceleration was great but after a week the car dramatically lost acceleration and the car does not make boost like it should.when boost comes in the clutch sound and feels like its slipping.when i press in the clutch i can here the clutch spin and rpm goes up and then back, not much but it's weird.one light i was at a light and car would not go into gear, i couldn't understand it because clutch pedal was soft but not to the floor.my question is did the boost burn out my clutch or what?:confused:
     
  2. turbowagon92

    turbowagon92 New Member

    Messages:
    47
    Likes Received:
    0
    Joined:
    Aug 23, 2006
    let me explain further clutch issue

    when i started drivin my turbo accord boost came fine,the torque was great,hard acceleration.but as a few days went by it felt different ,acceleration was not there .i could't understand it,it wasn't dramatic but i knew something wasn't right.this only happenend in first gear(where i noticed)but then second and then 3rd after a few more days of hard acceleration.torque was dramatically reduced.i started to worry.so one last time i tried to accelerate hard and when i got to the next light i put into nuetral and when light turned put my foot down on clutch pedal ,shifter did not want to go into gear 1st gear.i got into first(made loud grinding noise(that how i thought the clutch was gone)and everytime i switched gears.when i turned the car off and turned the car back on it was fine,went into gear and still does but i don't accelerate hard anymore because there is no torque and what is the sense,i don't want to be stuck in the middle of the road.also when at a stop and engaging in first i can feel that the clutch isn't grabbin like it should,very sluggish.the clutch that is in my car had been sittin for 2 years.the car drives now goes into gear fine but no torque(no acceleration),even when down shifting it doesn't grab like it should.:confused:
     
  3. turbowagon92

    turbowagon92 New Member

    Messages:
    47
    Likes Received:
    0
    Joined:
    Aug 23, 2006
    forgot one thing about clutch issue

    the loss of torque and the sensation of slippin clutch startin happening before that time it did not want to go in 1st gear from a stop.that night when i was at the light and it didn't want to go into gear from nuetral,when i did get the shifter into first,after that it went into each gear while drivin but made a grinding noise.when i came to a complete stop,it gave me alot of trouble to get it into first.but like said after i shut off the car and started it back:confused: hasn't done it since.the clutch from jump cant handle that amount of horsepower but i thought it would last longer than that.
     
  4. turbowagon92

    turbowagon92 New Member

    Messages:
    47
    Likes Received:
    0
    Joined:
    Aug 23, 2006
    what is the clutch hydraulics?(cylinder slave!)

    well if you mean the clutch cylinder slave or clutch master cylinder they are fine.they were checked out twice.i actually had the slave cylinder but my mechanic told me that wasn't the problem at the time.the clutch pedal would not pump up at all when car was put back together before all this, and come to find out the clutch could not be pumped up manually it needed to be pumped by machine to get stiffness.but pedal was soft from the get go,i told my mechanic and he said the soft pedal feel is how a hydraulic clutch is supposed to be.it's weird to me because i have a stage 2 clutch and when it was installed it was stiff as hell.somewhere i believe that when my car was put back together the same clutch was not there(i think it was replaced with a stock disc)i noticed a difference in pedal feel from jump street.so when i say soft it's compared to my original stiff pedal feel before built h22a and turbo.but i will make sure and let my new shop know about soft pedal feel,there is no leak of clutch fluid anywhere,fluid level is where it is supposed to be.thanks for the insight,you have been a big help.:confused:
     
Verification:
Draft saved Draft deleted

Share This Page