1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clutch problems, need help.

Discussion in 'Integra' started by TheminusMan, May 5, 2008.

  1. TheminusMan

    TheminusMan New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jan 21, 2007
    Location:
    WIsc
    I bought a B18A1 and swapped it into my civic. I noticed there was something strange with the clutch, adjusted the cable, etc. There was no spongeyness or pressure to the clutch, it was like it was solid as I attempted to disengage the clutch. Finaly just pulled the motor back out and took off the tranny, unbolted the the pressure plate and couldnt figure anything out. I made sure the clutch disc was on correctly (not backwards) and started bolting on the pressure plate, as i did this i noticed the fingers on the pressure plate moving in towards the motor. It does this as I bolt on the remaining bolts. There is no room for the throwout to push in the pressure plate when applying the clutch, and i dont know why.... The clutch disc and pressure plate appear to be original. Any help would be great. Thank you.
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    might need a new pressure plate
     
  3. TheminusMan

    TheminusMan New Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jan 21, 2007
    Location:
    WIsc
    If a pressure plate goes bad wouldn't it lose tension? this seems like the clutch disc is too big (fat). Or as if I had installed it backwards... but I didn't . I'm done with my swap except for this,..Anyone else with help full hints please post. Thank you.
     
Verification:
Draft saved Draft deleted

Share This Page