1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Code 22 Help Please?

Discussion in 'HYBRID -> EG-EK / DC' started by rufio0306, Aug 1, 2010.

  1. rufio0306

    rufio0306 New Member

    Messages:
    54
    Likes Received:
    0
    Joined:
    Apr 12, 2007
    Location:
    St. Cloud, MN
    I have a 94 EG with a 95 GSR engine swapped into it. I can get 2 good pulls past 5500 RPM, but then it goes into a limp mode and redlines at 5500 RMP. It has code 41 (o2 heater) not worried about that I am wiring in a 4 wire O2 sensor, but it also throws Code 22 (Vtec Pressure Switch) the wiring to the ECU is good and has good ground. is there a way to test the sensor with a MultiMeter?

    What kind of switch is it, an open and closed, or is it a actual pressure transducer where it reads actual pressure?
     
  2. rufio0306

    rufio0306 New Member

    Messages:
    54
    Likes Received:
    0
    Joined:
    Apr 12, 2007
    Location:
    St. Cloud, MN
    anyone? I Triple checked my wiring and its all good, are the sensors known to go bad often?
     
  3. E_SolSi

    E_SolSi Member of the 20 nut club Moderator VIP

    Messages:
    30,036
    Likes Received:
    3,970
    Joined:
    Sep 28, 2002
    Location:
    CT
    here are the pages regarding troubleshooting that error
     

    Attached Files:

  4. rufio0306

    rufio0306 New Member

    Messages:
    54
    Likes Received:
    0
    Joined:
    Apr 12, 2007
    Location:
    St. Cloud, MN
    Has good oil pressure to the switch, I hook up the genesys scan tool and it reads on when plugged in and off when un plugged (which means its working). still getting the code after hitting VTEC. Any ideas? Also it Hesitates when warm. maybe related?
     
    Last edited: Aug 14, 2010
Verification:
Draft saved Draft deleted

Share This Page