1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Code 43 O2 sensor what do I do? B16 CIVIC

Discussion in 'ECU's, Electronics, and Tuning' started by Gooseguir, Dec 27, 2003.

  1. Gooseguir

    Gooseguir Member

    Likes Received:
    May 4, 2003
    I swapped a B16 sirII into my '92 civic hatch in one weekend, yet it has taken us three months and it is still throwing a code, 41, which is O2 sensor I believe. We have tried hooking this thing up every possible way, it has two black wires one white and one green. I'm thinking maybe in the process of hooking it up we fried it, so I don't know what to do? Any help would be much appreciated. Also I was getting a code for the MAP sensor saying it wasn't hooked up, I couldn't find the MAP sensor on my engine so I took the sensor out of my old D15b engine and hooked it to my wiring harness and it's just dangling in my engine compartment, but it stopped throwing a code. (Temporary solution) Any help with this would be great also. Thanks a lot. I desperately need that CEL off so I can get my VTEC finally!!!!
  2. Joseph Davis

    Joseph Davis Member

    Likes Received:
    Dec 7, 2003
    92 CX, huh?

    And is this code 43 (fuel system) or 41 (O2 heater circuit)? I'm going to ASSume you meant 41:

    The black wires are for O2 heater circuit - hit one of them with switched power, I usually draw from the black/yel at ECU pin B1. The other black wire requires a ground via the org/blk at A6.

    Green is O2 sensor ground, I run that into the grn/wht found at D22.

    White is O2 sensor signal, just run it in through the existing one-wire O2 sensor feed.
Draft saved Draft deleted

Share This Page