1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

code 43

Discussion in 'HYBRID -> EG-EK / DC' started by socolsvtec, Jan 11, 2005.

  1. socolsvtec

    socolsvtec Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Oct 6, 2004
    Location:
    colorado
    b16a in a 98 civic hx converted to obd1.. p30 g00 ecu
    throwing fuel supply system code 43 has new filter, stock pump.. would walbro pump take care of prob?
     
  2. civiclxb16

    civiclxb16 Senior Member

    Messages:
    1,301
    Likes Received:
    2
    Joined:
    Dec 6, 2004
    Location:
    Poconos pa
    i don't know if it is going to get rid of the problem it might help it, does your car start? if you remove the fuel line from the fuel rail does fuel run from it? if so then there is a wiring problem somewhere check out all the fuel system wiring and then change the pump
     
  3. socolsvtec

    socolsvtec Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Oct 6, 2004
    Location:
    colorado
    car runs good no probs , miss , anything like that.. just started throwing code..
    cel isnt all the time it will come on then i turn car off then goes away for a while before comes on again not a constant light.. car just idling is fine no cel once i drive kinda get on it cel appears..
     
  4. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,623
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    well if you car runs fine then the only thing it can be is the o2 sensor. get yourself a new one. i have the same problem and im going to replace my o2 sensor with one i got from a junkyard.
     
  5. socolsvtec

    socolsvtec Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Oct 6, 2004
    Location:
    colorado
    ok ill try the o2.
    if that is the prob wondering why it would through fuel code?
    im kinda thinking i got a loose connectuion some where being its not an all the time thing
     
  6. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,623
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    everytime you turn your car off the code will reset. the ecu will store the code but wont display it until the problem happens again. but the o2 sensor pretty much controls the fuel, the ecu reads the signal from the o2 and adjusts the fuel accordingly
     
  7. socolsvtec

    socolsvtec Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Oct 6, 2004
    Location:
    colorado
    ok ill try a new o2
    would this mean im lean or rich, or the o2 is just starting to go bad?
     
  8. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    the o2 is just bad most likely- and it could cause a sputter.

    if the car runs fine at first and gets worse as its on longer, its the o2 being retarded. swap it out for a new sensor
     
  9. socolsvtec

    socolsvtec Member

    Messages:
    34
    Likes Received:
    0
    Joined:
    Oct 6, 2004
    Location:
    colorado
    new o2 tomorrow.. ill let you guys know the outcome thanks for all your info..
     
Verification:
Draft saved Draft deleted

Share This Page