1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Coilover Upper Mounts

Discussion in 'Civic and del Sol - EG and EK' started by EGDriver93, Sep 5, 2009.

  1. EGDriver93

    EGDriver93 New Member

    Messages:
    55
    Likes Received:
    3
    Joined:
    Sep 27, 2008
    Installed Buddy Club N+ Spec Dampers on the EG. Did not get the polyurethane upper mounts I thought I would. Should I get some Cusco's? or just use the originals on there?

    THE MAIN ISSUE is one side (driver side), seems to be poking through the mount hole a little higher than the passenger side. Any reason why? Ride height is the same on both sides. This is causing it to jump inside the opening.

    Any comments are welcome. Thanks guys.
     
  2. estes0122

    estes0122 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 5, 2009
    all you can do is to make sure you installed them correctly and ensure that they are sitting flush on tower mount and that they are properly installed in the bottom end of the strut also i do have a question for you how do i post a thread on this site i am not familiar with this exact one
     
  3. EGDriver93

    EGDriver93 New Member

    Messages:
    55
    Likes Received:
    3
    Joined:
    Sep 27, 2008
    They were def. installed correctly and they are very snug; no rattling, clicking, bouncing. My friend was saying that the upper rubber bushings on the old mounts could be SO worn, they are stretched out/ bad. Thoughts?
     
  4. estes0122

    estes0122 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Sep 5, 2009
    yeh that is very possible so describe this to me a little better then so the rubber bushing coming through the tower mount holes the one on the driver side is extended further out of the whole?
     
  5. EGDriver93

    EGDriver93 New Member

    Messages:
    55
    Likes Received:
    3
    Joined:
    Sep 27, 2008
    Exactly. The rubber bushing on just the driver's side is like 3-4" out of the hole, and the passenger's side is only like 2". Both the nuts that hold the washers onto the strut are very tight, but the driver's side just pushes through further. Weird.....
     
Verification:
Draft saved Draft deleted

Share This Page