1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cruise Control

Discussion in 'ECU's, Electronics, and Tuning' started by nash, Mar 25, 2003.

  1. nash

    nash Senior Member

    Messages:
    109
    Likes Received:
    0
    Joined:
    Dec 1, 2002
    yo i was just on the hwy a my cruise is not working. this light is not going on .
    what should i check?
     
  2. nash

    nash Senior Member

    Messages:
    109
    Likes Received:
    0
    Joined:
    Dec 1, 2002
    help
     
  3. saturn_boy96

    saturn_boy96 88 C1V1C 53D4N DR1V3R

    Messages:
    1,507
    Likes Received:
    1
    Joined:
    Dec 13, 2002
    Location:
    Sheridan, WY
  4. solblu

    solblu Senior Member

    Messages:
    378
    Likes Received:
    0
    Joined:
    Jan 17, 2003
    Location:
    Ricer
    IF it's not the fuse, check the clutch and brake switches. They are on the pedals and disengage cruise when you depress the pedals.
     
  5. nash

    nash Senior Member

    Messages:
    109
    Likes Received:
    0
    Joined:
    Dec 1, 2002
    i check the fuse and it's good.
    the problem is that light goes on the right , then there's another button on the steering wheel, while i hit that and set a speed a light should go on the dash, but there no light , and no working?
    what and where are the switches on the pedals. :unsure:
     
  6. nash

    nash Senior Member

    Messages:
    109
    Likes Received:
    0
    Joined:
    Dec 1, 2002
    i'll check the pedals what sholud i look for?
     
  7. nash

    nash Senior Member

    Messages:
    109
    Likes Received:
    0
    Joined:
    Dec 1, 2002
    thanks its working now
     
Verification:
Draft saved Draft deleted

Share This Page