1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Crx b16 problems

Discussion in 'HYBRID -> ED-EF / DA' started by b18c1civic97, Jan 19, 2004.

  1. b18c1civic97

    b18c1civic97 Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Oct 7, 2003
    We finished putting in the b16 into the crx, and got the car running but we bumped into a few problems. This is the first time me and my buddy have put a motor in a car, and its been fun and you guys have been great help so far, so here it goes. First off the car gave three different cel codes, a code 7, 14 and 22. The motor was a b16a with a pr3 ecu. 2nd problem that we bumped into is that the motor has no power at all, and feels like its going to die every time you start accelerating too much. Right now the car has no exhaust, and I had a friend tell me part of lack of power was due to not enough backpressure, but I don't think that would make the motor lack this much power. Any help is greatly appreciate it, no flaming though please, I'm trying to learn as I go. Thanks guys
     
  2. SubCultureNM

    SubCultureNM Junior Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Nov 28, 2003
    The lack of back pressure won't cause your power problem. This seems obvious, but are you sure you have your plug wires in the proper firing order? We did our B16A swap on Saturday and that was one of our issues. It's easy enough to get them mixed up.

    Check the easy things first!

    Brian
     
  3. StarBellieAngel

    StarBellieAngel Senior Member

    Messages:
    1,679
    Likes Received:
    0
    Joined:
    Jan 20, 2003
    Location:
    San Jose, CA
    i'm not too familiar with this swap, but when my car was doing the same thing it was caused by a vacuum leak... are all of the hoses hooked up properly?
     
  4. b18c1civic97

    b18c1civic97 Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Oct 7, 2003

    We got vacuum info off of a site, but it was a little difficult to read. Anybody have the vacuum diagrams for a b16 into a crx si, just to make sure we got it right, any help of someone is appreciated. :worthy:
     
  5. StarBellieAngel

    StarBellieAngel Senior Member

    Messages:
    1,679
    Likes Received:
    0
    Joined:
    Jan 20, 2003
    Location:
    San Jose, CA
    what site did you get the diagram from? i'll look for one... and also... another thing to check is proper idle speed... sounds like something wrong with the fuel system... almost like it's getting too much gas when you punch it, and it's not compensating. i wish i could help on the CEL codes, but i can't... i'm not good with that stuff. (i'm going to buy a code reader here in a few days, since we'll be finishing my swap)


    this link may be helpful to you
    ECU CODES

    To find out what each code means, check this table:

    1) Primary oxygen sensor- Defective circuit or unplugged/ Defective sensor
    2) Oxygen sensor "B" - Defective circiut or unplugged/ Defective sensor
    3) MAP (Manifold Absolute Pressure) Sensor - Defective circuit or unplugged/ Sensor
    4) CKP (Crankshaft Position Sensor) - Defective circuit or unplugged/ Defective sensor
    5) MAP (Manifold Absolute Pressure) sensor -Mechanical problem/ Disconnected piping
    6) ECT ( Engine Coolant Temperature) Sensor- Defective circuit or unplugged/ Sensor
    7) TP (Throttle Position) Sensor -Defective circuit or unplugged/ Defective sensor
    8) TDC (Top Dead Centre) Sensor -Defective circuit or unplugged/ Defective sensor
    9) CYP (Cylinder) - Defective circuit or unplugged/ Defective sensor
    10) IAT (Intake Air Temperature)sensor- Defective circuit or unplugged/Defective sensor
    12) EGR (Exhaust Gas Recirculation) -Defective circuit or unplugged/ Defective sensor
    13) Atmospheric Pressure Sensor - Defective circuit or unplugged/ Defective sensor
    14) IAC (Intake Air Control) Valve- Defective circuit or unplugged / Defective sensor
    15) Ignition Output Signal - Missing or defective ignition output signal
    16) Fuel Injector System - Defective circuit or unplugged/ Defective fuel injector
    17) VSS (Vehicle Speed Sensor) - Defective circuit or unplugged/ Defective sensor
    19) Automatic transmission lockup control Solenoid Valve- Defective circuit or unplugged/ Defective solenoid. A/T Only.
    20) Electronic Load Detector - Defective circuit or unplugged/ Defective sensor
    21) VTEC Solenoid Valve- Defective circuit or unplugged/ Defective solenoid
    22) VTEC Oil Pressure Switch - Defective circuit or unplugged/ Defective switch
    23) Knock Sensor - Defective circuit or unplugged / Defective sensor
    30) Automatic Transmission Signal- Defective circuit or unplugged/ Defective sensor
    31) Automatic Transmission Signal "B"- Defective circuit or unplugged/ Defective sensor
    41) Primary Oxygen Sensor Heater- Circiut malfunction
    43) Fuel Supply System - Defective or malfunctioning Fuel Supply Sytem
    45) System too lean or too rich - Malfunction in the fuel monitoring systems
    48) LAF (Lean Air Fuel) sensor - Defective circuit or unplugged / Defective sensor
    54) CKF (Crankshaft Speed Fluctuation) sensor- Defective circuit or unplugged / Defective sensor
    61) Primary Oxygen sensor circuit- High/ Low Voltage, Or slow response
    63) Secondary Oxygen Sensor circuit- High/ Low Voltage, Or slow response
    67) Catalyst System Efficiency Below Threshold- Malfunctioning catalyst system
    70) Automatic Transmission - Malfunction with Automatic Transmission Controls
    71-74) Random misfire in Cylinders 1-4- Condition present Creating Misfire
    80) EGR (Exhaust Gas Recirculation) Insufficient Flow Detected
    86) ECT (Engine Coolant Temperature) Circuir Range / Performance Problem
    90) Evaporative Emissions Contrlo System - Leak Detected In Fuel Tank Area
    91) Fuel Tank Pressure Sensor- Low Input
    92) Evaporative Emission Control System Control System- Insufficient Purge Flow

    it seems to me, that the first two will cause the problem. :)

    i boldfaced the CEL codes you said the ecu was throwing, and left the rest so you could copy and paste or print for your info. ;) hope it helps to fix these things... if not, i'll try to help you out some more!!!
     
  6. b18c1civic97

    b18c1civic97 Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Oct 7, 2003
    http://tech.hybridgarage.com/tech/manuals/...rvicemanual.pdf
    The vacuum lines we used was in page 115 because it seemed to resemble the most to ours. I'm looking everywhere for an actual b16 vacuum diagram, but no luck. I'll try to post pics of the swap to see if there is any mistakes that could be pointed out.
     
  7. b18c1civic97

    b18c1civic97 Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Oct 7, 2003
    Also thanks for the help, at the other forums that I used to use everyone seemed to go out of their way to make fun of people trying to learn. You guys are awesome :spin: :p
     
  8. b18c1civic97

    b18c1civic97 Senior Member

    Messages:
    296
    Likes Received:
    0
    Joined:
    Oct 7, 2003
    [​IMG]
    Awesome found this after some more searching, its too dark and cold to check it today, but I'll check it tomorrow after work, see if maybe the vacuum lines are wrong. The little part that goes in front of the intake manifold that has the vacuum line that runs into the intake tube, do I need to connect that part? because I'm using a cheap intake for the time being that doesn't have a hole for this part. Do I need this or can I just not use it without affecting performance. Once again, thanks guys
     
  9. StarBellieAngel

    StarBellieAngel Senior Member

    Messages:
    1,679
    Likes Received:
    0
    Joined:
    Jan 20, 2003
    Location:
    San Jose, CA
    there are so many b16's it's kind of rediculous sometimes. :)

    try looking in a manual for a 97 civic Si. i don't know if this will help as far as vaccuum lines go, since it's a completely different car... maybe if you cross ref with the manual for your Civic (like the helm's or hayne's)

    i don't have either... i'm trying to get my buddy to steal the honda's manual for my car, and the b16 hehehe
     
  10. Captinb16

    Captinb16 Member

    Messages:
    84
    Likes Received:
    0
    Joined:
    Dec 4, 2003
    I dont know if your in california or not but alot of that is just emmisions bs. There are only like 3-4 vacum lines that need to be ran. Map, FPR to the back of the intake manifold, theres like 2 others I dont remeber soory to tired. good night.. :)
     
  11. crxguy

    crxguy Junior Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 22, 2004
    i need the firing order 4 a 1 gen b16a
     
  12. canemode

    canemode New Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 17, 2006
    The firing order on my B16A is 1,3,4,2 hope this helps
     
  13. HONDA_PARTS_GUY

    HONDA_PARTS_GUY The Harvester Of Sorrow

    Messages:
    36
    Likes Received:
    0
    Joined:
    Oct 3, 2006
    StarBellieAngel,

    Just for clarification, not to be a jerk, they didn't produce a SI in 1997. Just didnt want him to go on a wild goose chase. :)
     
  14. CRXSIR1

    CRXSIR1 Junior Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Feb 5, 2003
    Location:
    Rockford,IL.
  15. TommYnY

    TommYnY HydroLockeD Type-S GuY

    Messages:
    30
    Likes Received:
    0
    Joined:
    Oct 17, 2006
    Location:
    Long IslanD NY
    i dont know if this is in the right section sorry moderators if it isnt.....i have very similar problems as b18c1civic97...only thing different is my obd 0 b16 is in a 94 obd1 dx hatch. i came across a obd1 pr3 ecu from a 92-93 jdm integra xsi and thought it wound be best for my application and is currently the ecu in the car. just like civic97 though i floor it and it just sputters like crazy like the mixture is extremely rich and its flooding itself. when thihs happens i turn off the car and wait a min and turn it back on and it revs freely. i just checked the cel codes 5 minutes ago and i have 3 5 7 10 and 41(map,map,tps,iat,o2)...my question is could these codes show up from my vacuams being wrong or are they defective sensors? if the sensors are defective what do i replace them w/ obd0 or obd1 or obd2 b16 sensors?.....

    also..when i am moving around vacuam hoses or disconnecting sensors is it necessary to unplug my ecu to reset it?

    im going to post pics of the manifold soon to be more specific as soon as i get batteries for my camera...the previos owner said he changed the intake manifold to a obd1 del sol b16 manifold but i dont know about that...

    all resposes and any input will be greatly appreciated...
     
  16. TommYnY

    TommYnY HydroLockeD Type-S GuY

    Messages:
    30
    Likes Received:
    0
    Joined:
    Oct 17, 2006
    Location:
    Long IslanD NY
    i just realized i def put this in the wrong section being that i got a eg......sorry mods!!!
     
  17. TommYnY

    TommYnY HydroLockeD Type-S GuY

    Messages:
    30
    Likes Received:
    0
    Joined:
    Oct 17, 2006
    Location:
    Long IslanD NY
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    thats the manifold..im no photographer! all input is greatly appreciated!!!!
     
  18. delsol_racer

    delsol_racer Junior Member

    Messages:
    176
    Likes Received:
    0
    Joined:
    Aug 2, 2006
    Location:
    watsonville ca
    jdm b16

    i have a jdm obd0 b16a engine dat will start up but the problem is dat it red lines at 3000-3500 don't know what to do so any one knows what to do tell me please
     
  19. goldgreen90ef

    goldgreen90ef goldgeen90ef

    Messages:
    642
    Likes Received:
    4
    Joined:
    Aug 19, 2006
    Location:
    cold ohio
    prob. wrong dizzy or dizzy wiring, had same problem w/ my old hatch, it was the wrong dizzy
     
  20. delsol_racer

    delsol_racer Junior Member

    Messages:
    176
    Likes Received:
    0
    Joined:
    Aug 2, 2006
    Location:
    watsonville ca
    kool thanx but what about codes my ecu have been punching out 6,9,10 so does vtec kick weather codes are present or not
     
Verification:
Draft saved Draft deleted

Share This Page