1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

crx w/ b18a wiring help....please!!!!

Discussion in 'HYBRID -> ED-EF / DA' started by xs2kx, Feb 14, 2004.

  1. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    whats going on guys looking for some help here.......i got a 91 crx si w/ a b18a the kid i got it from said they had some wiring problems...what im finding is that the car is very hard to start when the car is cold.......does anyone have like a wiring instruction link or something i can check out i really just want to go over everything and basically rewire the engine this way i know its wired right....any help is appreciated....Thanks Rick
     
  2. hammerdgolfer

    hammerdgolfer Senior Member

    Messages:
    275
    Likes Received:
    0
    Joined:
    Nov 21, 2003
    do you think you may just need a new starter? try tapping it with like a hammer when its cold...
    freind has the same problem, dont ask me why
     
  3. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    would the car still turn over?
     
  4. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    i have a d series starter that works great from my other crx.....would this work.....or do i need a b series starter???
     
  5. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    look noobs.... D and B do not changeover. SO no your D starter will not work on the B. but if you dont want to listen g'head and fucking try to put it on.
     
  6. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    dude just askin a question......its not a big deal....and its noob to the site not to hondas
     
  7. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    no one has any wiring info for an ls(b18a) into a 91 si.....if i was putting this motor in myself what would i have to change from my stock wiring to accomodate the ls....from computer to engine harness????
     
  8. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003

    1. DPFI to MPFI conversion... thats the only thing that comes to mind.

    as far as the you being new to the site.... there are things you should read before you post those are called FAQ's... this whole D adn B shit is explained in them.
     
  9. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    i hear what ya sayin man .... i have an si so its already mpfi.....theres nothing else wiring wise to do exept hookup my si harness to the ls motor and change my ecu to a obd0 ls ecu.....thats all.....im just tryin to see if the kid who did the swap on this crx before i bought it did the right thing....thanks for any help givin
     
  10. crx-si

    crx-si Member

    Messages:
    33
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    What year is the b18a from if its a 90 91 just use the stock harness
    from the crx no wiring changes needed.
     
  11. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    yeah its a 90-91........the problem im havin is that when the car is cold it just keeps cranking and cranking but wont start......after a couple minutes of tryin to start it....it will try and start eventually it will start and then when it warms up it runs great.......if i turn the car off it will start up fine but when its cold it wont start for nothing.....now i did plugs wires cap rotor o2 sensor and battery....just stuff to tune it up none of that stuff helped though.....is it possible the starter is shot or the distributor?????
     
  12. crx-si

    crx-si Member

    Messages:
    33
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Definatly not starter cuz it cranks over (is it dragging) there is. possibility of distributer or even main fuel relay(Does the fuel pump cut in all the time) weird problem.
     
  13. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    i switched main relays with my other crx and they both work....pump works.....while cranking fuel gauge goes to 38psi......just wont start...i dont get it??
     
  14. brian11to1

    brian11to1 Senior Member

    Messages:
    9,203
    Likes Received:
    21
    Joined:
    Jan 9, 2003
    Just sounds like it a cold natured engine. I dont know never had this problem.
     
  15. 894DSiR

    894DSiR Junior Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Sep 27, 2003
    it could be the fuel pump going bad, sometimes when they start to go bad they take a while to build up fuel pressure, this could be why it takes a while to start your car when its sat a while. you need good fuel pressure to start the car. hope that helps
     
  16. Doc_Honda

    Doc_Honda Junior Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Sep 25, 2003

    To see if this is the case... turn the key to the run position for a few seconds, then to start... see if this is the problem.

    Id check the rest of the fuel system too while your at it.

    I also assume you dont have a DX? And if you do, you have a resister box?
     
  17. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    thes car is a si...w/ resistor box......i had my brother watch my fuel pressure gauge when i start the car and theres 38 psi at the rail......i think i might have a bad ignitor.....??????????? any ideas on that?
     
  18. SIvic_1.8t

    SIvic_1.8t Junior Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Feb 16, 2004
    Pull a plug make sure you're getting spark.

    if not, then It's up stream of that, and could be your igniter/coil. Mine went out on my 94 teg, but when it went, it just plain went. Car would not start, kick, buck or anything. Just turn and turn, over and over.

    Check spark, then fuel.
     
  19. xs2kx

    xs2kx Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Feb 11, 2004
    thanks for the help guys......going to look into everything tomorrow.....seems to be a spark issue though.....since i got 38 psi to the fuel rail.......unless the injectors are shot......or not opening......ill keep ya posted thanks again!!!!
     
  20. smashed4thgen

    smashed4thgen Senior Member

    Messages:
    140
    Likes Received:
    0
    Joined:
    Oct 2, 2002
    is the ls motor from a 92-93 teg?
     
Verification:
Draft saved Draft deleted

Share This Page