1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d 15 b7 idle issues

Discussion in 'Civic and del Sol - EG and EK' started by knuckledog, Jul 22, 2008.

  1. knuckledog

    knuckledog New Member

    Messages:
    64
    Likes Received:
    4
    Joined:
    Jun 14, 2008
    Location:
    Ocala ,Florida
    hey guys, can ya help me out a bit? my car is stumbling at idle. when you start it cold, the engine runs fine, but as soon as it warms up, it runs like ass!, lopes etc,, but NOT consistently though, so today i got the balls to drive it on the freeway like 12 miles. it runs great on the road, but when you come to a stop it wants to stall out, the CEL came on on the freeway, but after i shut it off and started back up the CEL went out, but still runs shitty. i was thinking a bad throttle body? or iacv?, or maybe a tps? i know you can run a car just fine with a bad o2, so i dont think that is the issue,,,

    can you all maybe give me advice?
     
  2. knuckledog

    knuckledog New Member

    Messages:
    64
    Likes Received:
    4
    Joined:
    Jun 14, 2008
    Location:
    Ocala ,Florida
    anybody? please?
     
  3. Luis998

    Luis998 Honda Enthusiast

    Messages:
    2,867
    Likes Received:
    55
    Joined:
    Jan 14, 2008
    Location:
    Orlando, Florida
    Since I have had a similar problem before, I would start by checking the TPS. Unplug it, start it up and see if it does the same thing again. If so, it's the TPS.
     
  4. knuckledog

    knuckledog New Member

    Messages:
    64
    Likes Received:
    4
    Joined:
    Jun 14, 2008
    Location:
    Ocala ,Florida
    thx luis! i will try ....
     
  5. Luis998

    Luis998 Honda Enthusiast

    Messages:
    2,867
    Likes Received:
    55
    Joined:
    Jan 14, 2008
    Location:
    Orlando, Florida
    No problem. Let me know what happens after you try it. If anything, I can ask around and see what else I can find out.
     
  6. jesuslives

    jesuslives Banned

    Messages:
    65
    Likes Received:
    1
    Joined:
    Jul 24, 2008
    Location:
    in my garage
    change the pcv. the little plastic valve on the intake mani. and i had wires cut on my o2 sensor and it ran like shat. until i wired it bak up.
     
Verification:
Draft saved Draft deleted

Share This Page