1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D15b swap

Discussion in 'HYBRID -> EG-EK / DC' started by SCORPIONZZZZZ, Apr 14, 2005.

  1. SCORPIONZZZZZ

    SCORPIONZZZZZ Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Apr 14, 2005
    Hi my friend and I are working on a d15b7 to d15b swap and we're having some problems..will the stock harness from the d15b7 work for the d15b? we are using a p28 computer..if anyone can help what are the wires that need to be added? :blink:
     
  2. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Yes, you'll need some wires for vtec added, and o2 changed.
     
  3. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    As long as it's the same OBD as the B7.
     
  4. SCORPIONZZZZZ

    SCORPIONZZZZZ Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Apr 14, 2005


    Thank you very much 92b16vx..the car is a 93 honda civic dx 2dr coupe B7 swap to a D15b using the jdm intake manifold. We added the vtec selonoid wire and the and the EGR 3 wire. There was no vtec pressure switch when it came, just a bolt. We started the engine and now the engine light is on solid and wouldn't past 4,000rpm there is no CEL there is black smoke coming out of the exhaust we are using p28 ecu ..when we switch back to the stock ecu the light goes off and no exhaust smoke..could the ecu we possibly have a bad ecu? or is it something else? :huh:
     
  5. SCORPIONZZZZZ

    SCORPIONZZZZZ Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Apr 14, 2005

    PLEASE HELP..
     
  6. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Well, you don;'t need the EGR system for starters. Could be a bad ECU, try a known good one.
     
Verification:
Draft saved Draft deleted

Share This Page