1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D15Z1 - D16Z6 Swap Questions

Discussion in 'Engine Building' started by NeonPinHead, Jan 9, 2006.

  1. NeonPinHead

    NeonPinHead Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 9, 2006
    I bought a 92' Civic VX and the stock motor was burning oil bad so i came up on a D16Z6 for $300 with the P28 ECU. I bought a new o2 sensor from autozone (bosch universal 4-wire o2 sensor) and rewired it, it has no check engine light now. Well my real question, is there anything else i need to wire? I'm running the full Z6 motor, head, and intake manifold. I had to use an IACV from an accord i think... it matched up so i went with it. I also had to take the TPS off of the Z1 and put it on the Z6 since the Z6 didn't come with one. I also took the oil cooler off the Z1 and worked it into the Z6. i'm running the Z1 tranny. and everything else that's bolted to the engine compartment/fire wall is from the Z1... the motor runs a little funny... it ildes irraticly from like 600 to 1000 and back and forth from there, when the idle goes from 600 to 1000 it has a sort of putt. another problem is MPG i topped off my tank and drove 130 miles and it went down a half tank. any information, advice, or comments would help out a lot. thanks.
     
  2. NeonPinHead

    NeonPinHead Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 9, 2006
    so far i've checked the IACV, MAP, TPS, and the vaccume sensor on the back of the intake manifold near port #1. I recently bought new spark plugs and a new fuel filter. I had the timing done by a mechanic since it was cheaper than buying the gun. Tomorrow i'm going to replace the PCV valve. other than that maybe fuel injectors which i plan on buying as soon as i can anyway they're over 10 years old, spark plug cables, or maybe the fuel pump? anyone have any other suggestions?
     
  3. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    the 600-1000 bounce is usually one of 2 things. the EGR or the O2 sensor. I personally dont trust bosch products, so i would test it and make sure you are getting the correct signal from it. after that i would pop the EGR off and see if the passage is clogged.

    I will say this though. The fact that you got a z6 and p28 for $300 bucks is a really good deal. i doubt its your fuel pump, and the wires are always a smart move. make sure you go with NGK wires tho...there are none better.
     
  4. NeonPinHead

    NeonPinHead Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 9, 2006
    i don't have an EGR on the motor anymore, it's the Z6 intake manifold. but i'll recheck the o2. it's not a vaccume leak and the PCV is fine, just cleaned it out with some carb cleaner. it doesn't seem to be bouncing as much right now. it idles at normal temp. with the idle adjust screw tightend all the way
     
  5. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    Reikos Honda knowledge

    H>>>>>>>>B>>D

    But i can tell you that when i replaced my O2 sensor (with a honda one) it stopped doin that mess, but make sure its just bouncing back and forth between .4 and .6 (if memory serves...repair manual is in the trunk and its too late for me to be goin outside)
     
  6. NeonPinHead

    NeonPinHead Junior Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 9, 2006
    could the o2 be causing all this trouble? I mean i am getting errors 1 and 41 sometimes...
     
Verification:
Draft saved Draft deleted

Share This Page