1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d16a6 swaped ef trouble codes

Discussion in 'General Tech and Maintenance' started by tjscivic, Sep 14, 2009.

  1. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    I just got my d16a6 in my ef. It does run but it runs like poo. It sounds like it misfires all the time.I cant rev the engine when I gun it, but sometimes when I slowley give it gas it will rev up and not misfire but only sometimes. I am throwing codes 4, 7, and 10. Code 4 (4 flashes) is the Crank angle sensor, Code 7 (7 flashes) is the Throttle angle, and Code 10 (10 flashes) is the Intake air temperature. My first question is where is the IAT at? And does anybody know where I could look to find my problems to get it running right?
     
  2. RoughKnight

    RoughKnight Christmas Car

    Messages:
    846
    Likes Received:
    25
    Joined:
    Aug 4, 2009
    Location:
    Ottawa, Ont
    Lets combine threads, mine is asking the same question. Almost.
     
  3. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    I read your thread and was not going to make another one but im having more codes than you.
     
  4. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    I can figure out 7 and 10 but 4 I need help with.
     
  5. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Anybody ever have this problem?
     
  6. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Ok so I replaced the distrubter with a new one, it was fine at first then after running for about 30 seconds the CEL came back on for the crank sensor. Any body have a clue as to what could be my problem?
     
  7. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    timing off?
     
    1 person likes this.
  8. D15Beater

    D15Beater HNFTuning

    Messages:
    551
    Likes Received:
    8
    Joined:
    Jun 8, 2007
    Location:
    Concord N.C.
    Cam timing out? This would result in the above described and throw codes.
     
  9. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    thats what im guessing
     
  10. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Ok so I did the cam timing again and again. I moved it one tooh clockwise and one counterclockwise and it ran worse when I moved it. There is 2 lines on the crank pulley, these 2 lines need to be even with the timing mark on the timing cover right? And the cam gear needs to say up, and the 2 lines on it need to be level with the head? My belt is pretty loose, is this normal on a honda? Sorry for all the dumb questions, I just got out of DSM's after about 10 years, and honda stuff is so different.
     
  11. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    time to change the belt...and tensioner..
    there should be 4 total marks on the crank pulley...3 of which are timing and 1 to the right of the timing marks..this is
    TDC..so you set the motor to tdc..set the cam marks to their spots and put the nelt on..rotate it 3 teeth and tighten the tensioner
     
  12. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    on the D16A6, the 2 lines on the cam gear do not line up with the top of the head - there is a 3rd line at about the 7 o'clock position - this line needs to line up with the pointer on the inside timing belt cover

    [​IMG]
     
  13. tjscivic

    tjscivic New Member

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    There is a total of 5 marks on the crank pulley. There are 2 together and down the way there is 3 together which im guessing is for BTDC.
     
Verification:
Draft saved Draft deleted

Share This Page