1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D16y7 to d16z6 using stock engine wiring harness

Discussion in 'HYBRID -> EG-EK / DC' started by bruce974, Jun 27, 2012.

  1. bruce974

    bruce974 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 27, 2012
    Hi, all

    I swapped my d16y7 out of my 98 civic non-vtec. i swapped a d16z6 vtec engine and i still only have the d16y7 harness and P28 ecu with a harness converter.
    I added some wires for the vtec pressure switch and vtec solenoid.
    the engine starts normally but when I start to accelerate,
    the engine is not performing too, the others symtomps are:
    It's very hard to start the car, engine will stumble upon acceleration too and I have a CEL code 9( crank angle sensor fault).

    I use all d16z6 sensors ( dizzy, injectors, throttle body, IACV...)

    can you help me please?
     
  2. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    Replace the sensor. It's down by the crank. Or.....maybe it's a bad connection/not plugged in properly.
     
  3. bruce974

    bruce974 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jun 27, 2012
    In D16Z6, I think crank angle sensor is integrated in the dizzy.
    I have already tested another dizzy and the problem persists :(
     
Verification:
Draft saved Draft deleted

Share This Page