1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D16Y8 problems

Discussion in 'Civic and del Sol - EG and EK' started by custompainter, Jan 16, 2007.

Thread Status:
Not open for further replies.
  1. custompainter

    custompainter drive it like U stole it

    Likes Received:
    Jan 16, 2007
    central CT
    i just put a d16y8 in my 99 civic dx i'm re-using the stock dx harness and distributer. i just made a conversion harness to go from the obd2b to obd2a so i can use the p2p ecu i've all ready swapped pin 16 to 15 on the A plug for the fuel
    the car turns on and runs but the idel is all over the place kinda vering up and down and when i try to rev it up it die's right out when off the gas again and picks back up and holds idel and starts vering again
    i tryed the CKF jumpers i tryed switching IAC's around (b23 - b15 - b6) did nothing i also checked if it was wrong and it was the other way (a14 - a12 - a13)
    wasn't so thats my prob!
    I also hooked the old ecu back up and switch pin a15 and 16 back turned back on and ran fine but's the (dx ecu p2e NON VTEC) any thoughts for a fix
    I also have tryed to adjust the timing a little and got nothing
    I know it in the wiring but i have no clue where to start

    another thing is there a way to get the vtec to work with the p2e ecu i dont care if the damn ecu is a p2p or a p2e i just want the vtec to kick in i have a turbo for this car too i just want to get all the power i can
    aem fuel rail, aem fuel presure reg., rc 310cc injectors, ihi turbo with a 8 lbs wastegate, hks blow off, ACT stage two clutch and flywheel, pilot cat back,
    i just want this thing to f-cking go i'm out in conneticut and no one has a sick single cam and the extra horse from the vtec is what i'm trying to get so if theres a way to hook it up with out the ecu please let me know because an 90 horse engine without the turbo is a joke and well that extra 30 40 horse will be nice i also have the distributer from the d16y8 but i have no harness for the motor if need be i will get the harness but i'm all out of money and i want the sh-t done

    . alright i went thruogh the steps pulled the back up fuse and reset i did this first with a p75 got a code 16
    then i did it with the p2p and got code 14 - 22 - 65
    p75 - 16 fuel injector problem
    p2p - 14 IAC Valve (Idle Air Control) defective circuit or unplugged / defective
    22 VTEC Oil Pressure Switch defective circuit or unplugged / defective oil pressure switch
    65 Oxygen Sensor Heater (Secondary) malfunctioning or defective oxygen sensor heater
    as far as the code 65 goes i know that there is no ground hooked up from pin D13 cause there was no cross refference when i made the harness conversion i can add it easy but i dont know what to tie it to ?
    as far as the code 22 goes i know that the presure switch is hooked up but there is two wires coming off a (blue/black + black) blue/bla is connected to the ecu (i hard wired that 18 gauge wire) the black isn't hooked up i didn't think it was needed = anyone know where it goes ?
    now the code 14 i have no clue i know it a three wire setup and that there on the b23,b15,b6 do you think they need to be just switched around or what

    see the p75 doesn't through a code 14 it throughs code 16
    so what the hell is up with the p2p
    another thing i just found i dont have three pins hooked up
    1) IP + HO2s pump cell + pin C23 black wire
    2) IP - VS - HO2s common pin C24 red wire
    3) VS + VS cell voltage pin C25 white wire
    do i need these theres no cross reference that i can find to tell me where they go
Thread Status:
Not open for further replies.

Share This Page