1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D16y8 slipped clutch?

Discussion in 'Civic and del Sol - EG and EK' started by gus79915, May 2, 2011.

  1. gus79915

    gus79915 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jan 26, 2011
    Hey guys went to drags on Friday, ran car so did mild burn out. Took off great shifted to second no slipping then when I went into third my rpm slowly started to decrease till it felt fully engaged. That was my first run second did same but instead of third it happened in second but shifted strong into third , do you guys think my clutch is going out??? My mods are zoom stage 3 clutch kit, nitrous, I/h/e, intake manifold, p28 s300 skunk2 coilovers, o and bf g-force radials Any input would be appreciated thanks
     
  2. jdmeg07

    jdmeg07 New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    May 2, 2011
    Sounds like you need a new clutch bro. . .

    Btw I'm new to this and I got some issues I wanted to post my own ad but don't know how! I havve a b18b1 from an integra 2000 in my eg hatch. . Its was auto but I converted my car to stick as well as the motor it was auto and I got a ls tranny. . . Harness is auto. . . What do I need to change to convert stick? P75 ecu obd1 but motor harness is obd2. . Car is running ok not great. . Idles at start 1200 goes a lil down to 1000 then gies I'm to 1500. . Seems like it has to do with the throttle body maybe?? Idk if auto and 5speed throttle body r the same? B18 back fires some time not that often??? Timming is good vacume leaks were checked sensors are plugged in? What can it be?
     
  3. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
    Jdmeg..sorry man, not only did you thread jack, but your concern is way off topic.:eek: You can run a search on auto to manual swap.

    Gus, it does sound like a faulty clutch. but.... There could me many variations to pin point the actual solution. How long ago was the clutch installed? Was the hydro line bled correctly, is your rear main seal possibly splattin oil to your disc? What condition is your slave cylinder in?...etc...etc..

    Its tough to determine, especially with performace clutches..
     
  4. gus79915

    gus79915 New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Jan 26, 2011
    Yea I know it's a yr old I installed it myself( allowed 1000mile break in) lines bled, all seals brand new, idk today was pretty hard on it at work and did not show any sign of it slipping! Even did that 4th gear test by any chance in hell do you guys think maybe I spun my tires n loss traction??? Forgot to mention only happens when i was running it with nitrous with out it's fine. I have zex box with wot feature thanks
     
  5. RHDism

    RHDism Right Hand Drive guru

    Messages:
    259
    Likes Received:
    9
    Joined:
    May 1, 2011
  6. Matts96HB

    Matts96HB . Moderator VIP

    Messages:
    6,483
    Likes Received:
    390
    Joined:
    Apr 16, 2006
    i highly doubt that you lost traction in third on your d16y8 with nitrous. are you sure that you had your foot all the way off of the clutch?
     
Verification:
Draft saved Draft deleted

Share This Page