1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

d16z6 has no spark

Discussion in 'HYBRID -> ED-EF / DA' started by b16a eg, Mar 25, 2007.

  1. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    so we just swapped in a d16z6 into my friends 90 civic si and we have no spark. he ordered a obd 1 conversion from rywire.com so im pretty sure we got everything. the fuel pump pumps fuel to the injectors but there is no spark. any ideas?
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    does tha car turn over ? if it does check the main relay and ecu
     
  3. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    yeah it turns over and everything. just no spark. theres nothing wrong with the motor either it was my motor and i sold it to him after i got a b16 and it ran when we took it out
     
  4. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    any ideas any one? i'll give you guys a full rundown of what we used so maybe its easier. we used the 90's wiring harness since i used the d16z6's on my car. we had to use the 90's injectors since the z6 injectors didnt fit the harness. we ordered a new icm. order the conversion harness from rywire. we're using the z6 ecu. and i think thats all we changed. we checked the coil earlier and it seemed to be okay. so i dont know what could be wrong
     
  5. jason22ga

    jason22ga jason91si

    Messages:
    65
    Likes Received:
    0
    Joined:
    Feb 5, 2007
    Location:
    griffin,ga
    what distibutor/ecu are you using z6 or stock
     
  6. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
  7. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    what are we supposed to check with the ecu? we are using the z6 ecu, if that makes a difference....
     
  8. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    the main relay makes the 2 clicks and the cel shuts off like its supposed too. so any other ideas
     
  9. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    no ideas anyone???? we need to get it running
     
  10. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    have you tried a diffrent ecu yet
     
  11. b16a eg

    b16a eg New Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Mar 25, 2007
    we haven't tried a different ecu yet, only the one from the 95 z6
     
Verification:
Draft saved Draft deleted

Share This Page