1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D16Z6 in 89 DX Hatch

Discussion in 'HYBRID -> ED-EF / DA' started by jginter, Apr 23, 2004.

  1. jginter

    jginter Junior Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 19, 2004
    Location:
    iowa
    I have a 89 dx hatch with a 95 d16z6 swap in it and was done with all si parts except for the injectors which are from the d16z6, but I needed to modifiy the harness because they are obd1 and everything is wired obd0. Vtec kicks in at 5200. The car is running very slow and the rev limiter kicks in at 6500. Amost any thing can beat it right now which really sucks. I was wondering what could be wrong and what could be done to fix it.
     
  2. BigJ

    BigJ I'm just about that action Boss. VIP

    Messages:
    11,090
    Likes Received:
    408
    Joined:
    Oct 4, 2002
    Location:
    Washington
    My first question is, how is it wired?

    Please elaborate...Are you using DX components, what?
     
  3. jginter

    jginter Junior Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Apr 19, 2004
    Location:
    iowa
    The car was originally a dx. I think the wiring is dx. Almost all of the components are si.
     
  4. liquid00meth

    liquid00meth Senior Member

    Messages:
    3,201
    Likes Received:
    0
    Joined:
    Nov 26, 2002
    Location:
    Laconia, NH
    are you sure VTEC is wired properly? And keep in mind that z6s only have 130hp.... I don't know what kind of power you were expecting???
     
  5. BigJ

    BigJ I'm just about that action Boss. VIP

    Messages:
    11,090
    Likes Received:
    408
    Joined:
    Oct 4, 2002
    Location:
    Washington
    If it still is DPFI then it will not be fast. I have a dpfi d16z6 unfortunately at the moment, and damn the things a dog.
     
  6. dreded90crxsi

    dreded90crxsi Senior Member

    Messages:
    133
    Likes Received:
    0
    Joined:
    Mar 12, 2004
    The z6 actualy only has 125hp. If I were you I would convert to obd1. I've herd from many people that ran the z6 and mini me setups at obd0 said they saw a big differance when they went to obd1.
     
Verification:
Draft saved Draft deleted

Share This Page