1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

D16z6 swap

Discussion in 'HYBRID -> EG-EK / DC' started by wisemansoji, Jun 28, 2004.

  1. wisemansoji

    wisemansoji Senior Member

    Messages:
    175
    Likes Received:
    0
    Joined:
    Dec 17, 2002
    I put a D16z6 into a 93 base model sedan for my GF. I used the new d16 engines harness and connected it to the cars body harness. I'm using a p28 ECU. The problem is that the car idles at 1500 when it is started and at a grand when its warm. The ECU is throwing codes Mapping sensor, O2 sensor and vtec solonoid, this one makes sense cuz I haven't wired v tec yet.

    I guess my question is can I use the cars body harness for a d16z6 or do I have to change it to a d16 harness. because theres two plugs for the throttle body sensor and when one is plugged in the idle wants to jump and the other the car idles high.
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    if the 93 had a 1 wire o2, you need to run a wire through the firewall to the ecu for the z6's 4-wire o2.

    other than that, check yoru idel adjustment screw...
    and really, you CANT diagnoos a poorly runnign car when it still has codes.

    fix the codes, THEN fix the problems
     
  3. wisemansoji

    wisemansoji Senior Member

    Messages:
    175
    Likes Received:
    0
    Joined:
    Dec 17, 2002
    the d16 has another 02 sensor wire? where do I run this wire and to what pin on the ECU.
     
  4. wisemansoji

    wisemansoji Senior Member

    Messages:
    175
    Likes Received:
    0
    Joined:
    Dec 17, 2002
    Does it matter what throttle body I use. A d16 or a d15.
     
Verification:
Draft saved Draft deleted

Share This Page