1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dead ECU???

Discussion in 'ECU's, Electronics, and Tuning' started by vmk23, Aug 11, 2003.

  1. vmk23

    vmk23 Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Aug 8, 2003
    I was messin around with the wiring under my hood and i think i may have fried the ECU. My dash lights all work and stuff and the car even turns over but it won't start at all. The check engine light is staying on even when i ground out the D4 wire (Check Engine Input) on my P28 ECU. I will check my fuel pump but for now let's assume that it is ok. How can i check and make sure my ECU is ok? I opened her up and there was no visible damage. PLEASE HELP

    THANKS!
     
  2. HardLowrdRanger

    HardLowrdRanger Member

    Messages:
    99
    Likes Received:
    0
    Joined:
    Nov 18, 2002
    Location:
    Phoenix, AZ
    Try it in a friends car... :)
     
  3. HondaMoCo

    HondaMoCo Senior Member

    Messages:
    322
    Likes Received:
    0
    Joined:
    Jan 8, 2003
    Location:
    lancaster/palmdale So Cal
  4. AsiAnVenOm

    AsiAnVenOm Member

    Messages:
    75
    Likes Received:
    0
    Joined:
    Jan 25, 2003
    I'm sure you poped your fuse..check under the hood or dash for the fuse...ECU isn't easy to fry onless you straight molest it...same shit happened to me...all i had was a poped fuse.
     
  5. vmk23

    vmk23 Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Aug 8, 2003
    Yeah this morning i found the "Alternator Solenoid" FUSE blown...never heard of it. I haven't started the car yet but i'm going to try it now. I'll let you guys know how she's running.

    What does the Alternator Solenoid do anyway???

    One more thing: Anyone have the harness that attaches to the IAT sensor on a 92-95 civic Si manifold? or where i can find one? The junk yards want me to buy the whole darn engine harness! I'll be back later...
     
  6. vmk23

    vmk23 Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Aug 8, 2003
    WAHOOOOO!!! That was it, just a fuse... Took me a few days to get it. I got her started and am throwing a code 10 i believe on my P28. Anyone know what that is off hand???
     
  7. blundar

    blundar Senior Member

    Messages:
    115
    Likes Received:
    0
    Joined:
    Jul 11, 2003
    Location:
    Sinsinnasty, Ohio
    10 = IAT ...
    check the connections to the intake air temp on the intake manifold. You might have a loose wire or the IAT + idle valve reversed or sumthin.
     
Verification:
Draft saved Draft deleted

Share This Page