1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

detonation/pre-ignition... HELP!!!

Discussion in 'HYBRID -> EG-EK / DC' started by APEXi, Sep 6, 2005.

  1. APEXi

    APEXi Senior Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Jun 5, 2005
    hey guy i need ur help bad!! im almost 100% sure im hearing detonation from my motor.. if i hold my revs at 4.000rmp my exhaust starts to pop like crazy.. also once i reset my ecu im only throwing a code 20 but then once i've started my car up and reved it a lil it throws the knock sensor..
    ok this is my setup - 94 eg hatch 0BD2 b18c4 motor (same as a gsr motor but with lsd) OBD2 engine harness, OBD1 cabin (underdash harness) harness and a JDM OBD1 P72 ecu..

    now im still running a OBD2 distributor, so could this possibly be the problem??

    how can i fix this problem guys? wot do i have to do?

    any help would be very much appreaciated... Thanx
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    obd1 ecu will work fine with obd2 distributor, so long as it is wired right.

    detonation sounds like popcorn poping in a metal pan. are you sure its detonation, and not just loading up with fuel and backfiring or something else? usually det. occurs only at WOT, not when you're just sitting there revving
     
  3. APEXi

    APEXi Senior Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Jun 5, 2005
    it also pops like mad while drivng at times.... if its not det.. would could the problem possible be?

    it throws the knock sensor everytime to then motor is reved.... it also smells quite rich and the engine get really hot really quickly...it dusn't overheat tho...
     
Verification:
Draft saved Draft deleted

Share This Page