1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dohc ZC sputtering

Discussion in 'General Tech and Maintenance' started by Spooner, Apr 15, 2004.

  1. Spooner

    Spooner Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Apr 8, 2004
    Just got the ZC in my car and if I try to rev past 3000 rpms it starts sputtering really bad. Could this be because of water in gas? If so I plan on fixing it sometime tomorrow. Because the gas has been in the car for some time now(over 6 months). I am pretty sure I know how to fix it if that is the case. zc is in a 88 crx si with a si tranny if any of that matters.
     
  2. BigJ

    BigJ I'm just about that action Boss. VIP

    Messages:
    11,091
    Likes Received:
    408
    Joined:
    Oct 4, 2002
    Location:
    Washington
    Yeah that sounds like the problem. I wouldn't run it on bad gas if it was me though.
     
  3. Spooner

    Spooner Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Apr 8, 2004
    Yeah...I was taking it to a friends so that we could put on an intake and front bumper...I'm not gonna drive it again until I get the stuff to fix it with, and then I will drive to a gas station....but I hope that's it. Might be my ECU? Plan on getting a 89 teg ECU anyway.
     
  4. cheese9988

    cheese9988 Senior Member VIP

    Messages:
    1,990
    Likes Received:
    251
    Joined:
    Apr 25, 2003
    Location:
    Lowell, MA
    make sure there are no vacume leaks anywhere. Just put mine in and I found a couple "ports" on the back of the manifold, plug those up and reset the ecu, that fixed the same problem I had.
     
  5. Spooner

    Spooner Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Apr 8, 2004
    It wasn't any "port" on it. I think it was just the gas. Gonna work on it tomorrow and try to fix it. Hopefully that will fix it and I won't have any/many more problems out of it.
     
  6. Spooner

    Spooner Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Apr 8, 2004
    Okay what I thought it was didn't fix it. Sometimes when I start it, I can rev it to 3k without a problem. Other times it acts like a rev limit and won't go past 3000 rpms and starts studdering/sputtering/backfiring everytime you try to go past 3000 rpms. When it does go past 3000 rpms, once it hits 6000 rpms it won't go any further than that. When you try to rev it up after that it won't go past 3000 rpms. Any idea what the problem is? I am still using the si ecu and tranny. Any help is appreciated. I have 3 days to get it fixed. Quick replies would be appreciated.
     
  7. thiebert

    thiebert Senior Member

    Messages:
    104
    Likes Received:
    0
    Joined:
    Nov 1, 2003
    Location:
    Vancouver
    sounds like timing check it. my zc redlines at 7000 and does not sputter. I had a d16z6 that had a similar problem after i did a head gasket on it. turned out the camshaft was out one tooth
     
  8. Projectzc

    Projectzc Senior Member

    Messages:
    103
    Likes Received:
    0
    Joined:
    Oct 3, 2003
    I would check timeing First most likely the problem. Other then that Clogged injector. I suggest takeing them out of the manifold and cleaning them up with some brake cleaner. Clean each injector screen. This is a much better then just injector cleaner in the tank. You could also be haveing a miss fire. Bad coil, Bad Ignitor, Bad Wires or Bad cap and rotor. You might want to take off you Dizzy and make sure it spins freely if it is hard to turn that is you problem. As the bearing in them are know to go. Their should be some resitance but if you got to try hard to turn it, it is bad. If it continues after all those things are in working order I would say you got a valve problem one is sticking or bent. But that would be the worst and is most likely not your problem. What computer are you running any check engine lights? The si computer will runn it a little ruff but it should not spudder
     
  9. Spooner

    Spooner Junior Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Apr 8, 2004
    Using the regular 88 crx si ecu. Check engine light comes on when I rev it to 6000 rpms and it starts acting funny. Gonna take it out to a friend of mine's shop to see if he knows what is wrong with it.
     
Verification:
Draft saved Draft deleted

Share This Page