1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Door won't lock/unlock

Discussion in 'Civic and del Sol - EG and EK' started by 92stoccord, Jan 24, 2013.

  1. 92stoccord

    92stoccord Big Member

    Joined:
    Sep 21, 2008
    Messages:
    4,444
    Likes Received:
    175
    Location:
    Salem, Ohio
    I've been having this problem for a while and I don't know if you guys have any tips. My drivers side door won't lock with the key. It feels like the rod just deflects instead of working the lock mechanism. The power locks will work no problem. So to lock my door I have to stand outside the vehicle and hold the outside handle and push the power lock button. Of course the actuator is bad in the passenger door, so I only have power locks on the drivers side. But the passengers side key hole works fine.

    When I unlock it, I have to hold the key all the way in the unlock position then pull the door handle while holding the key there. Cause it will just lock again if I pull the key out, or put it back into the middle position.

    This is only an intermittent problem, but its more often than not. Sometimes its fine, sometimes its broken. Any ideas?
  2. Briansol

    Briansol Admins Admin

    Joined:
    Nov 18, 2007
    Messages:
    18,910
    Media:
    29
    Albums:
    2
    Likes Received:
    1,022
    Location:
    CT
    The rod is probably bent. pop the door panel off and inspect. it will probably be obvious.
  3. dc4dude

    dc4dude Member

    Joined:
    Aug 12, 2008
    Messages:
    895
    Media:
    2
    Likes Received:
    13
    Location:
    chicago, il
    I agree^^^^, but what caused the rod to bind, is that the lock mechanism components are getting rusty... You would be better off taking everything apart and lubing everything up... I had a similar issue with my older civic. Lubed everything up and worked like new.
  4. 92stoccord

    92stoccord Big Member

    Joined:
    Sep 21, 2008
    Messages:
    4,444
    Likes Received:
    175
    Location:
    Salem, Ohio
    I probably bent the rod rolling around with a bad window regulator (so I could easy fix it if I had to) I'll take it apart when it's warmer and lube everything up, and get it working again. Just wondered if it might be the lock cylinder...












    While I'm here... Wasn't there a different front end that came on the EK? Almost like the Acura? Was that just the 1.6CL?
  5. E_SolSi

    E_SolSi Member of the 20 nut club Moderator

    Joined:
    Sep 28, 2002
    Messages:
    28,566
    Likes Received:
    2,116
    Location:
    CT
  6. 92stoccord

    92stoccord Big Member

    Joined:
    Sep 21, 2008
    Messages:
    4,444
    Likes Received:
    175
    Location:
    Salem, Ohio
    CL, EL, its an Acura. This must be what I saw. I saw it when I was noobier, and then I forgot what it was. I thought it was ferio, but obviously I was wrong.
  7. Briansol

    Briansol Admins Admin

    Joined:
    Nov 18, 2007
    Messages:
    18,910
    Media:
    29
    Albums:
    2
    Likes Received:
    1,022
    Location:
    CT
    its canadian.
  8. 92stoccord

    92stoccord Big Member

    Joined:
    Sep 21, 2008
    Messages:
    4,444
    Likes Received:
    175
    Location:
    Salem, Ohio
    Fucker locked me out last night. Came out of work, had to pull the handle with the key in unlock position. Started my car, grabbed my ice scraper, and scraped off my windshield. When I got done I went to open the door and it was locked. Thank god for aaa.

Share This Page