1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ecu codes #1, #2, #22. little help please.

Discussion in 'Integra' started by zellis, Jan 15, 2007.

  1. zellis

    zellis New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Jan 1, 2007
    first i'd just like to say that not only did i go through the forum, but i literally read EVERY single post pertaining to codes #1, #2, and #22. now what ive gathered is that 1 and 2 are o2 sensor issues. seems that some people have fixed the issue by replacing their sensors all together. some had IAT issues. and a good deal of the posts i read had no real resolution. so my question is that if anyone has some additonal advice, i would love to hear it. like anyone i'd like to be sure that the actual sensor is what i need before i drop $100 on a new one. also, as far as code #22 goes, im not all that sure how to approach that one. although this is my second honda, this is my first REAL car project and im not familiar with vtec pressure valve issues. is it just some piece i can replace? what all can go wrong that will make that code display? please let me know. thanks.
     
  2. MikeBergy

    MikeBergy Blah blah blah....

    Messages:
    3,646
    Likes Received:
    1
    Joined:
    Oct 9, 2003
    Location:
    Central Coast, CALI
    What model integra? Year, Trim, Swap?

    Sound like they could all be wiring problems. That is usually the case for the vtec solenoid. You might try to clean out the vtec solenoid screen as well.
     
  3. zellis

    zellis New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Jan 1, 2007
    its a 90' gs 2dr b16a2 obd0. i read it could be solenoid screen issue, or wiring issue. not sure how to troubleshoot it.
     
    Last edited: Jan 16, 2007
  4. MikeBergy

    MikeBergy Blah blah blah....

    Messages:
    3,646
    Likes Received:
    1
    Joined:
    Oct 9, 2003
    Location:
    Central Coast, CALI
    And what ecu are you using?

    If it's an obd0 vtec ecu, you will either a) need two o2 sensors, and they need to be wired correctly, as in, it's not just an unplug the old ecu and put the new one in kind of thing, or b) a chipped ecu running a BRE rom with the secondary o2 disabled.

    For your vtec, 1)check the wiring for continuity and 2)clean out the screen if you haven't already.
     
  5. zellis

    zellis New Member

    Messages:
    23
    Likes Received:
    0
    Joined:
    Jan 1, 2007
    "jdm b16 ecu(pr3)" apparently is the ecu. also i havent been able to even pop the hood in the last 2 days to attempt to clean the solenoid filter or even look at the wiring cus it has been sleeting and snowing, ha. in texas of all places. crazy weather we are having.
     
Verification:
Draft saved Draft deleted

Share This Page