1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EG with B18b1 bad mpg

Discussion in 'HYBRID -> EG-EK / DC' started by chacal06, Aug 23, 2009.

  1. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Hi I have a 93' civic with a b18b1 when I got it back from the shop ( fix pistons now has high porformance piston ) it was giving me super bad mpg then I checked the codes and I had no map sensor tp sensor was bad and code 22 I think vtec solinoid I bought the map sensor and adjusted tp sensor that fixed it a little but I notice it still drains more gas then what I expected for a 4 cylinder !! I noticed that the higher rpm more gas it drains but I don't even go over 3000 only on 5th gear...also I notice the needle goes down a little and goes back up but not to where it was at first ! Well I want to know if any one know what I should check or change ? Thanks in advance to any help I get very appritiated !!
     
  2. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,455
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    b18b1 doesn't have vtec... thus no vtec solenoid. re-check your codes.

    what tranny are you using?
    ecu?
    tire size?
    tire pressure?

    and what are you seeing for mpg?
     
  3. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    I know b18b1 doesn't but for some reason mine does that's how I bought it maybe they tried to do the ls/vtec but that's the code it shows...I have p28 ecu and about the tranny I'm not sure I just bought the car like that how could I check ? I have 17 in rear 15 in front tire pressure is right ... to tell u the truth I'm not sure wat mpg I'm getting because I don't trust it to wait for the empty light to show
     
  4. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,455
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    you should have a p75 ecu. the p28 is for a d16z6. it's likely running in limp mode because its not seeing all the required sensors. buy a p75.
     
  5. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Is there anything I need to kno about connecting an ecu ? Or its as simple as disconnecting the old one and connecting the new one ? Also if I have a map sensor but from a wrong year does it make a big difference ?
     
  6. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    15psi? Thats about half of what should be in them. And yes the ECU just un-plugs.
     
  7. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,455
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    @map... wrong year, depends. as long as its the same obd as your computer you're ok. obd0 map sensors are different than obd1/2
     
  8. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Thakns for all the help !!....also my iacv is bad ama buy a new one that make a difference on how much gas it it waste ?
     
  9. Bobby17772

    Bobby17772 New Member

    Messages:
    785
    Likes Received:
    6
    Joined:
    Jun 11, 2009
    Location:
    Enfield, CT
    just remember to disconnect the battery before you change the ecu
     
  10. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    Whys that?
     
  11. Bobby17772

    Bobby17772 New Member

    Messages:
    785
    Likes Received:
    6
    Joined:
    Jun 11, 2009
    Location:
    Enfield, CT
  12. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    Because there is no reason to.
     
  13. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Does it have to b obd1 or 2 from the same year ?So does any one knows where I can get a p75 I live in los angeles california
     
  14. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,455
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    obd1, 94-95.

    there's probably 10 in the for sale section here, 100 on ebay, and probably some on craigs list for well under $100.
     
  15. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    I did my calculations and I did 130 miles with 7 gallons....I'm not sure if its good or not can some one help me out...and I forgot to say that the check engine light code is vtec solenoid because it has b16 vtec head and I was thinking of chipping my p28 ecu to be for a b18 and to have vtec is it a good idea or not ?
     
  16. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Can somebody help me get better mpg ??!! I wanted a good gas saver but its not saviing me much...also sometimes I get a smell of gas while I'm drivin I'm not sure why that is but it may be part of my problem but can somebody HELP ME!! Thanks in advance
     
  17. necessaryevil

    necessaryevil New Member

    Messages:
    65
    Likes Received:
    0
    Joined:
    Jun 6, 2009
    Location:
    in da 503
    ok go out get the RIGHT computer for your car, drive it around for a while, then come back if youve got any more problems, your gas milage sucks couse your car has the wrong ecu
     
  18. chacal06

    chacal06 New Member

    Messages:
    110
    Likes Received:
    0
    Joined:
    Aug 23, 2009
    Location:
    los angeles CA
    Ok ama try it out I hope that's my problem...ill keep u updated with what happend when I change the ecu ! Thanks
     
Verification:
Draft saved Draft deleted

Share This Page