1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Emergency! Need help!

Discussion in 'HYBRID -> EG-EK / DC' started by wiredjosh, Jul 3, 2004.

  1. wiredjosh

    wiredjosh Member

    Messages:
    59
    Likes Received:
    0
    Joined:
    Jun 16, 2004
    Location:
    loovull, ky
    I have just finished swapping an SirII B16 into an 96 HX. We're using an OBD2-OBD1 harness and a P61 ECU. The car cranks, I have fuel pressure, I have spark, but it won't kick over. There are three things that I think might be wrong, but I'm not sure how to check...

    1... I had to rewire the distributor for the OBD1 dist, and I used this for the distributor wiring, matching ECU pin -> wire color -> OBD1 wire color. Is there any way I could have gone wrong, or that this wouldn't cross over right from the obd2 harness into the obd1 ecu? I'm a little confused from overthinking this thing so much.

    2... It occurred to me that since the OBD1 integras (I only know for sure on the LS/GS) use an injector resistor box, that I might need to add one to this setup. Does anybody know? I certainly don't, and I don't know the 92-93 GS-R's very well. Has anybody used this ecu before?

    3... I am not getting any CEL at all. When I jumper the check connector, I don't get anything at all, and I don't when I turn the key on either. What's up with that? I'm going to check the bulb and see if the bulb works, but I just don't know beyond that.

    Please help me! I REALLY need to get this car running!
     
  2. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    My common response is....check your timing, especially if you played with the distributor.
     
  3. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    Check compression in all of the cylinders, check the timing of the crank and the cam gears. When I did my swap it had spark and fuel but would not start. The cam gear was off 90 degrees!!
     
  4. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Also check grounds, and make sure the battery is fully charged.
     
  5. wiredjosh

    wiredjosh Member

    Messages:
    59
    Likes Received:
    0
    Joined:
    Jun 16, 2004
    Location:
    loovull, ky
    I have checked and double checked the firing order, injectors, grounds, spark, distributor wiring, etc. I've been keeping the battery on a starting charger, so I know that I have plenty of juic. However, when I checked compression, it worried me. I have good compression on 3 cylinders, around 150, but on one I am only getting like 80. How bad is that? Does that indicate bad rings, or does it mean other stuff too? I am also wondering about that injector resistor box. Does anyone out there have a 92-93 gs-r? I haven't yet had a chance to pull off the timing cover and check the belt, which will probably be next. The belt went on super easy tho, didn't even move from TDC when I took off the old belt. I think it was the easiest time I've ever had putting on a t-belt. I'm getting pretty stumped here tho.
     
  6. wiredjosh

    wiredjosh Member

    Messages:
    59
    Likes Received:
    0
    Joined:
    Jun 16, 2004
    Location:
    loovull, ky
    OK, so now it's running, and idles fine, but it doesn't want to pull at all. It feels weak like crazy. Could this be because it's not compressing well on that one cylinder, or do you think that it's because it's going into limp mode? It really feels like it's in limp mode, or like it's not getting enough gas.

    Since the guy's CEL isn't working (probably removed by some schmuck who didn't want to fix something when he was selling it... ) I'm gonna take it to Autozone and have them pull the codes for me tomorrow. I'm hoping it's something mild. I do know that it's going to be throwing a Knock sensor code, since the knock sensor is broken and we're waiting for a new one to be send up to me. Can a knock sensor cause that kind of power loss?
     
Verification:
Draft saved Draft deleted

Share This Page