1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Code Error - Fuel to Rich (Bank 1)... help

Discussion in 'HYBRID -> EG-EK / DC' started by jdmnation, Aug 5, 2004.

  1. jdmnation

    jdmnation Junior Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jul 29, 2004
    I just did a 2000 B16A2 swap into my 99 Si I put stage 3 clutch and lightweight flywheel and performace cam gears... and it has stock B16 Header and my old Cat witch came from 99 Si... So after that I get a engine light on the error is the same each time it said Too Rich Fuel ( Bank 1 ) ... dose any one known how to fix this... do i need a new cat or header or both... i do have a Full back Cat on the car... help..
     
  2. sihatchback_RL

    sihatchback_RL Senior Member

    Messages:
    272
    Likes Received:
    0
    Joined:
    Jul 4, 2004
    got AEM or hondata? might be those cams bro. tune it a little and see what happens.
     
  3. MXDesa

    MXDesa Senior Member

    Messages:
    927
    Likes Received:
    2
    Joined:
    Apr 19, 2003
    Location:
    Queens, New York
    Oxygen Sensor my man! Have someone test it, it should be at 2 volts on idle up to 4.6 at wide open. Have someone test it. The computer knows how much fuel to throw in by the readings from the oxygen sensor. Wrong reading, computer is gonna dump fuel to try and correct a lean condition
     
  4. jdmnation

    jdmnation Junior Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jul 29, 2004
    I put a new Oxygen Sensor in the car an still did the same....could it be my values need adjusting... I putted to the computer and it was tested fine... on idle..
     
  5. MXDesa

    MXDesa Senior Member

    Messages:
    927
    Likes Received:
    2
    Joined:
    Apr 19, 2003
    Location:
    Queens, New York


    Did you have to do any of your own wiring on the O2 sensor? If so make sure its correct, and if you can test the voltage output of the Sensor at wide open and 2500 RPM
     
  6. jdmnation

    jdmnation Junior Member

    Messages:
    29
    Likes Received:
    0
    Joined:
    Jul 29, 2004



    Looks good. with the O2 Sensor but i still get the engine light for the same error and this is what i did since to try to fix it... I got the values adjusted and replaced the fuel pressare Regaulator and also check the Ingentor for leaks and still the engine light came back on.....
     
Verification:
Draft saved Draft deleted

Share This Page