1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Cranks but doesn't start-- Help!

Discussion in 'HYBRID -> EG-EK / DC' started by joebeajetski, Aug 22, 2006.

  1. joebeajetski

    joebeajetski Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 20, 2006
    I have a 99 civic ex 5spd - D16Y8 swap one for another. I got everything installed and I think I have the wiring hooked up correctly, but I could be wrong. I know for sure that the engine is not getting fuel, so there is an obvious problem. The distributor is from my old engine so I don't know what issues can come from that. I was thinking of getting the diagnostics kit to get a reading. I need to get this thing running asap. Please help me its my first swap! Thanks.
     
  2. Turbo&Auto

    Turbo&Auto Nick Go FAST!!

    Messages:
    3,269
    Likes Received:
    29
    Joined:
    Jan 9, 2006
    Location:
    East Burg, PA!
    If you know its not getting fuel, no matter what you do it wont run. Fix that first, then keep covering the basics first. Does it have spark?
     
  3. welfare

    welfare Ancient Member

    Messages:
    1,120
    Likes Received:
    9
    Joined:
    Apr 19, 2004
    Location:
    New York
    if you aren't getting fuel, make sure that you have the engine grounds hooked up, one from the valve cover to the left shock tower or left side of radiator support, and the other from the transmission (near the far right upper mount) to the front bulkhead/frame/whatever you want to call it.
    usually if you had fuel before and aren't getting it now it's because you forget the engine ground during the swap.
     
  4. joebeajetski

    joebeajetski Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 20, 2006
    I know its not getting fuel and the grounds are connected correctly. I'm gonna check out all the wiring and make sure its correct. Any thoughts on why I wouldn't get fuel other than the ground? It work fine before. Thanks.
    -Joe
     
  5. welfare

    welfare Ancient Member

    Messages:
    1,120
    Likes Received:
    9
    Joined:
    Apr 19, 2004
    Location:
    New York
    when you say no fuel do you mean that the fuel pump isn't running or the injectors aren't working??? if the pump isn't running check your fuses if the grounds are ok, then delve into the wiring, if its the fuel injectors, then check the wiring in the engine compartment, make sure that you connected the 4 wire plug on the right side of the engine compartment (pass side shock tower) that plug is for the fuel injectors.
     
Verification:
Draft saved Draft deleted

Share This Page