1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Lacking Power

Discussion in 'General Tech and Maintenance' started by Jspec, Mar 21, 2003.

  1. Jspec

    Jspec Junior Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    Mar 20, 2003
    Location:
    Vancouver, B.C. CANADA
    I just put a newer b20a in my 88' prelude after breaking the crank in half in the first engine. Now i have no power under 3500rpm, when the engine gets hot and i bring above 4000rpm it stutters, and when i first start it in the morning it will rev up and down from like 1200-2000rpm, up and down. I need some help.
     
  2. asmallsol

    asmallsol Super Moderator

    Messages:
    8,074
    Likes Received:
    3
    Joined:
    Sep 28, 2002
    Location:
    Houghton/Livonia Michigan
    check to see if you have any cooling problems like low coolant, stuck thermostat, leak somewhere.
     
  3. Jspec

    Jspec Junior Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    Mar 20, 2003
    Location:
    Vancouver, B.C. CANADA
    ya i have no leaks, a new thermostat and the level is fine.
     
  4. chevy302dz

    chevy302dz Senior Member

    Messages:
    209
    Likes Received:
    0
    Joined:
    Oct 1, 2002
    It's probably fuel or electronics, check for codes then work your way through the fuel system starting with changing the filter, then check all the wiring. Since this is a new install it's your problem lies in one of these areas
     
  5. Jspec

    Jspec Junior Member

    Messages:
    21
    Likes Received:
    0
    Joined:
    Mar 20, 2003
    Location:
    Vancouver, B.C. CANADA
    thanks will do
     
Verification:
Draft saved Draft deleted

Share This Page