1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Light Came On

Discussion in 'ECU's, Electronics, and Tuning' started by legutki, May 6, 2003.

  1. legutki

    legutki Senior Member

    Messages:
    258
    Likes Received:
    0
    Joined:
    Feb 24, 2003
    I have a pr3 in a 89crx HF. The engine light came on and it wont rev past 3k. After a while the engint light went off and it was back to normal and ran fine until I brought it back down to idle and then the engine light came back on and it wont rev past 3k. When the light came on i thought i heard something switch on. I just finished my swap and it has not run right yet except for a coulpe of minutes here and there. Any suggestions???
     
  2. legutki

    legutki Senior Member

    Messages:
    258
    Likes Received:
    0
    Joined:
    Feb 24, 2003
    oh yeah the ecu light is not blinking or throwing any codes. What does that mean? is the ecu jacked up?
     
  3. AllMotorMonster

    AllMotorMonster Senior Member

    Messages:
    542
    Likes Received:
    0
    Joined:
    Oct 13, 2002
    Location:
    Inland Empire foo!
    Put the stock chip back in and see if the problem goes away.

    If you're using the stock chip, then the ECU is fubar'd.
     
  4. B16

    B16 Super Moderator VIP

    Messages:
    11,539
    Likes Received:
    534
    Joined:
    Sep 30, 2002
    Location:
    yay area, CA

    well, you said the light is on, so it must be throwing a code, are you checking it correctly?
    http://www.hondaswap.com/articles/viewer.php?id=20
     
  5. Baker

    Baker Senior Member

    Messages:
    754
    Likes Received:
    0
    Joined:
    Oct 9, 2002
    Location:
    Schaumburg, IL

    thats what i was about to say. The light doesn't just blink on its own, you have to jumper it
     
  6. HardLowrdRanger

    HardLowrdRanger Member

    Messages:
    99
    Likes Received:
    0
    Joined:
    Nov 18, 2002
    Location:
    Phoenix, AZ
    Actually, OBD0 ECUs do blink on their own... If the light stays on it's throwing code 0 which sends you into limp mode (where you can't rev over 3K)... That does mean either something is loose in the ECU or external wiring or your ECU is fubar'd as AllMotorMonster said... It doesn't normally go in and out of limp mode if it's fubar'd so check everything!!! Good luck man...
     
  7. MaaseyRacer

    MaaseyRacer Senior Member

    Messages:
    2,980
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    Location:
    San Francisco, Ca.
    uhhh, actually an obd0 ecu throws the code on the actual ecu when the check engine light comes on, so that mean pull back your carpet and look at the ecu, and count the blinking lights as indicated here:
    http://www.hondaswap.com/articles/viewer.php?id=20
     
  8. legutki

    legutki Senior Member

    Messages:
    258
    Likes Received:
    0
    Joined:
    Feb 24, 2003
    Thanks guys im going to start checking wires. Im sure its probably the ones i added at the ecu :(
     
Verification:
Draft saved Draft deleted

Share This Page