1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Sputters

Discussion in 'General Tech and Maintenance' started by slipvayne, Aug 26, 2003.

  1. slipvayne

    slipvayne Member

    Messages:
    43
    Likes Received:
    0
    Joined:
    Aug 24, 2003
    Location:
    hesperia, Ca
    I have a 87 lude si. I bought it in January, when i bought it i noticed that after a few minutes after driving the pgmfi light would come on but the car ran good. About 2 months ago it started sputtering in low gears. Its getting worse and worse. It happens in every gear now and when i try to accelarate i bogs out and i have to down shift. Any help will be appreciated. Thanx
    I have changed my plugs and filter. i also checked the injectors and they seem to work fine.
     
  2. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    Are you sure its not your clutch slipping?

    Check that out.
     
  3. slipvayne

    slipvayne Member

    Messages:
    43
    Likes Received:
    0
    Joined:
    Aug 24, 2003
    Location:
    hesperia, Ca
    its a new clutch. Would the rpms drop too if the clutch is going out. cause they drop
     
  4. dveit

    dveit Well-Known Member VIP

    Messages:
    5,361
    Likes Received:
    79
    Joined:
    May 5, 2003
    Location:
    DMV
    Hmm, the rpms usually drop when the clutch is slipping, but only right before its burnt out. Usually if the clutch is just beginning to slip, you will be giving it gas and the RPM's will go up but it will seem like the clutch is not engaging and nothing will happen. But, since its a new clutch, I highly doubt that its your clutch. Unless you REALLY don't know how to drive stick.

    Nothing really comes to mind, lemme do some searching around and i'll get back to ya.
     
  5. slipvayne

    slipvayne Member

    Messages:
    43
    Likes Received:
    0
    Joined:
    Aug 24, 2003
    Location:
    hesperia, Ca
    lol yeah i know how to drive stick. :D it really doesnt feel like the clutch. i dont think that the engine would bog like that if it was the clutch. i noticed to day that when its idleing it jumps up and down alittle. Fuel Pump going out? :axe:
     
  6. sportlinecrx

    sportlinecrx Banned

    Messages:
    6,020
    Likes Received:
    0
    Joined:
    Sep 28, 2002
    it could be a number of things. here's what i can think of off top of my head:

    - clutch out of adjustment (engaging too soon/not giving it enough gas)
    - clogged air filter
    - clogged fuel filter
    - incorrect timing
    - worn distributor cap and/or rotor
    - bad spark plug wire(s)
     
  7. slipvayne

    slipvayne Member

    Messages:
    43
    Likes Received:
    0
    Joined:
    Aug 24, 2003
    Location:
    hesperia, Ca
    I check all of those . Thanx for the help. i'll post if that fixed it. Thanx guys
     
  8. sportlinecrx

    sportlinecrx Banned

    Messages:
    6,020
    Likes Received:
    0
    Joined:
    Sep 28, 2002
Verification:
Draft saved Draft deleted

Share This Page